Not Centering After a Plate Solve

I’ve been using SGP to run a CDK20 on a L500 in Chile for a couple of years and auto-centering with plates solve has always worked flawlessly. Two weeks ago, I installed a new 24" on a L600 and while I was at it, I updated both SGP and PW4, which in hindsight was a big mistake! Now I’ve got three things that changed. When I updated from SGP to, the new version lost my plate solver (PW2) and the catalog files. So, I reloaded them and now plate solving again works fine. However, the system no longer centers the scope after the plate solve. I’ve confirmed all the settings (from my previous version) and I’ve gone through the logs for both SGP and PW4 to look for errors and I see none. I can supply time synced log snippets for SGP and PW4 for anyone who wants to double check. This is a mission critical problem and if I can’t solve it, I’m going to have to try to roll back to an earlier version of SGP.

Any suggestions???


Unfortunately, the issue here is likely too compex for speculation. If you’d like to include logs showing the failure, they will likely provide detail sufficint to troubleshoot.

SGPro - Help

Yesterday, I carefully reviewed both the SGP and PW4 logs with Kevin Iverson at Planewave and here are the conclusions:

  1. SGP is computing the correct offsets.

  2. When SGP sends the new coordinates to PW4, it is not applying the offsets, which appears to be why the mount is not moving. The mount is sitting at position x,y and SGP is telling it to move to x,y so the mount does nothing. Therefore it looks like this function might be broken.

I’ve attached the appropriate log snippets so let me know what you think. I really need to get this working again.


Thanks for the analysis here… What we really need to see is the next slew attempt after that sync. If you’re able to share the logs with us, it would be of great help. Further guidance here:

SGPro - Help

Thanks for looking into this Ken! Here’s a link to the two log files.


Seems like maybe I don’t have permission? The error given is not useful.


Ken, I’m really sorry about that. I’m copying the link for everyone. One more try:

OK, thanks. I think have figured out what’s happening. There are sync options in the telescope tab (Control Panel and Equip Profile Manager). They are:

Sync, Target Offset, Scope Offset and None… in SGPro 4.3, it should be

Sync, Offset, and None

This is an error on our part and I will correct it.

I suspect that, in your sequence and / or profile, this is set to Scope Offset which does essentially nothing. After the fix I release, you’ll select Offset here. For now, to get things going, you will need to select Target Offset

I should note that I am not 100% certain about this… I will keep looking, but this is the thought for this moment.

Thanks Ken! I tried Target Offset and it didn’t work either, but I will try it again tonight and report back. In my previous version the “Scope Offset” setting always worked perfectly.


You got it. I just tried it with Target Offset selected and it worked perfectly. Thanks a million for such excellent support! I really appreciate it.


1 Like

What changed between you first and second attempt with “Target Offset” that made the first one fail and second one work?


Sorry for the slow reply Eric…I’ve been traveling in Chile.

The first time that I tried it with Target Offset, it solved with a very small error compared to when it ran with Scope offset. Therefore the correction value was below the minimum offset that I had set. Because the original solve was so far from what I originally saw, I thought something was wrong. I was clearly too hasty and just not careful about exploring the behavior. There was clearly some “inantentional blindness” involved simply because I didn’t expect the target offset to work just based on what I had been doing using the previous version of SGP. Lesson learned. BE MORE CAREFUL when testing different settings!