Occasional corrupted FITS file

Once in a while a FITS image won’t open in Pixinsight, or any other FITS program like FITS Liberator. When I run that image through NASA’s FITS Verifier, I get the following message:

File name: 2020-11-29_015434_143.2deg_120sec_1x1_Red_frame1.fit
Run Number 28737

          fitsverify 4.20 (CFITSIO V3.470)              

*** Error: (from CFITSIO error stack:)
Couldn’t find the string ‘SIMPLE’ in the stdin stream.
This does not look like a FITS file.
failed to copy stdin into memory (stdin_open)
failed to find or open the following file: (ffopen)

**** Abort Verification: Fatal Error. ****

Any idea what the problem is? This might happen with one image a night, although I haven’t really tried to quantify it yet.


Edit: In case it matters, SGP writes images to the local hard drive on the capture laptop in my obs, which then synchronizes with another drive (previously via Google Drive to a local drive, now to a network drive). I later move the data from that drive to a local hard drive on my processing PC. I usually discover the problem when trying to calibrate the data in Pixinsight.