Only the old zwo driver works

It is notable that only the old ZWO driver worked with my 1600 M camera… The driver generates an error message but only the old driver works with the camera. It took me a while to figure out why I was not getting an image.

Do you mean that ZWOs ASCOM driver is not working with some models of their cameras?

Yes. It took me a while to figure it out. The camera is a ZWO1600M Pro. “ASI Camera 1” would not produce an image, although the camera connects to it. I had to use “ZWO Camera”. An error message is generated when I select it, then you select which camera. That worked. I can send the log if you like.


I also posted a link to the ASCOM diagnosis log. I still would like to get my Senso Septo focuser to work with SGP…it does not do auto focusing.

We can look, but the ZWO ASCOM driver is not treated differently from any other ASCOM camera and you may need to bring it to ZWOs attention. But maybe it’s something we can troubleshoot… no harm in looking.

I don’t see any of this stuff. Last I see on that thread is a note that you sent a support request to PrimaLuce.

Here, again is the Dropbox link.

To which SGPro log does this ASCOM log correspond? The one on the other thread?

I think this is the SGP log it corresponds to.

That also should show the issue with the ZWO camera.

That SGPro log file is not the right one. If you use the issue reporting tool, it will organize them and note the time ranges they cover so you can find the matching one pretty quickly. If you don’t want to use that, the log file names are actually dates in the format YYYYMMDDHHmmSS

I sent logs with the reporting tool.