Paramount ME ignoring meridian flip

Hello, everybody

My Paramount ME (using TheSky6 and ASCOM Telescope Driver for TheSky) is configured to perform a meridian flip after 5 minutes past the meridian.
But instead, it just keeps tracking the target without changing its side, until it reaches the maximum limit of the mount, preventing the scope from crashing with the pier.

So I went and checked the logs, and saw this:

[09/14/20 23:33:18.705][DEBUG][Sequence Thread][SQ;] Checking if Meridian Flip is needed
[09/14/20 23:33:18.705][DEBUG][Sequence Thread][SQ;] Meridian flip not needed, telescope on Unknown side

It seems that the side of the pier is not being reported by the driver.
Then I checked its settings.


“Can Get Pointing State” is checked, and when hovered a pop-up informs that it’s “for GEM mounts to get the side of pier”.

So there doesn’t seem to be a reason for it not to be reporting the side of pier to SGP so it can perform the meridian flip.

How should I proceed from here?

Have you enabled auto flip in Telescope Configuration / Telescope options / Data (Use Auto Meridian Flip), click on “Set” and set configuration as required.

Yes, it is enabled and set, as you can see in the attachment.


What is your side of pier set to ? (in EQMod it’s one of the Ascom options)