PhD now has Multi star

Just a note for those who are not aware but PhD2 now supports multi-star guiding as of 2 days ago. I have not tried it yet (clouds) but plan to…

I tried it last night. I haven’t analyzed the data/numbers yet, but my impression is that I did see perhaps a 10-20% better guiding behavior. The other thing I like is that PHD2 often chooses a star that is on the very edge of the field, which I’m never comfortable with, and the multi star option I think averages out the star profiles resulting in less swings or errant moves from that edge star.

I ran a trial the first day the Multi-Star guiding was offered .
I wanted to compare it with a 3hr single star session done a couple of nights prior.
Clouds prevented me from getting a full 3 hour comparison.
However, what I saw was an improvement in RA (and possibly Dec).
The folks at PHD2 noted that the improvement was around 15% reduction.
If anything I feel their estimate is conservative.


I have to say I’m that on my system I’m impressed with with the new multi-star guiding in PHD2. My system is usually really good anyway since I’m using a Paramount MX+ and running T-point and ProTrack. Usually my guiding is 0.25-0.30 total RMS with 10 sec guide exposures. With the multi-star guiding the total RMS is now 0.15-0.20 pixels (around 0.35")!


In fact, our remote system has exactly the same setup and I tired it last night. Just one night so maybe it was just better seeing but it was noticeably better guiding at 580mm and 3.5 sec guide exposure, with a 800 msec delay.

Have to agree also - was surprised by the amount of difference. Only had couple hours to test before clouded in and won’t get another chance for many many days based on long range.

Only one short anecdotal test but was best guiding I’ve had with current equipment setup (over a year).

I’m using a separate guide scope and not OAG (w/150 refractor and MX+). I wonder if the multi-star compensates for my often less-than-ideal guide star focus (due mostly to temperature swings). I should probably read up more on this multi-star function …


I tested PHD2’s multi star guiding with my 1830mm system using an OAG with a LodeStar X2 guide camera. I ran 10 minutes of single star guiding followed by 10 minutes of multi star guiding. This sequence was repeated for about 90 minutes. The results showed single star guiding had a “Total RMS” average of about 0.60" and multi star guiding had a “Total RMS” average of about 0.48". So, this simple test had positive results.

I did notice that most of the time, the multi star runs only selected four or five stars even though there appeared to be several more stars visible in the FOV that looked equally usable.


Hi there, do I simply update the latest version of PHD to get multstar guiding installed?

Yes, just update to the latest version of PHD2 and enable multi star on the guiding tab (brain icon/Guiding).

Yes, and no. You need to install the latest Development Snapshot Build, not the latest full release (which does not yet have multi)

You can find those here

The MultiStar option is only in the current dev build so you will also have to uncheck the “Only check for major releases” in the Global settings tab to download dev versions

Very many thanks for getting back to me with clarification, much appreciated. As PHD currently works Ok and my technical ability lets me down on occasions, I think I will wait until the feature is distributed in a fully tested version. I assume that this will happen at some stage?
Thanks again for feedback

For what it is worth, with PhD2 I have seldom, if ever, found any major problems with beta versions.

Thanks for that, are there any other features in the beta version I should watch out for?

Out of curiosity, has anyone else encountered an issue with multi-star guiding via PHD2 in which the mount won’t settle within the parameters set in SGP? In my equipment profile, I’d previously required the mount to settle within 0.6 pixels for 5 seconds. I’d never had a problem. After downloading the new build and checking multi-star guiding, it won’t get anywhere near that, generally never falling below 1.2 pixels and so the sequence won’t begin capturing subs. If I go into PHD2 and uncheck multi-star guiding, it then settles with those parameters almost immediately. I’m using an AP1100 with absolute encoders so I don’t think it’s some new issue with the mount. Thought I’d ask before trying the PHD forum and submitting logs.

1 Like

Yes, I have 3 rigs (2 EQ6 and a EQ5) running and I’ve observed this failure twice, once on an EQ6 and the second time on the EQ5. It was as you described, the settle distance would stay around 1.4 to 1.2 but the PHD2 graph looked good. When I switched off MSG, the settle distance then started to decrease as normal - but there was no indication on the PHD2 graph that it was settling any better than before. But it is infrequent - I’ve had 4 all night sessions with the 3 rigs running and only observed it twice and found another instance in the PHD2 log.

As one of the beta testers for the new multistar algorithm I am a little embarrassed to say that I experienced this failure too on several occasions when using one of my long focal-length imaging rigs. And just as has been reported above, after over a minute of waiting for settling to finish despite the guide traces looking fantastically smooth, when I deselected multi-star guiding PhD immediately reported settling finished to SGP and imaging then continued. The reason I did not report this to Bruce was because I was also running five other imaging rigs simultaneously and none of them experienced this settling issue across any of the 10+ imaging sessions, so I assumed it was simply an intermittent problem confined to my particular equipment environment.

The only hint of a possible cause is that, when this problem occurred the guiding was “one-sided”, meaning one or both of the traces were predominantly on one side of axis and rarely crossed the axis. Perhaps that constant bias across multiple stars was enough to upset settling for some reason.

Thanks for confirming that I am not the only one who has experienced this. As is customary in these situations, before I could experiment further, my imaging laptop crashed. As soon as I deal with that, I’ll try to submit logs.

I upgraded to the dev PhD2 to utilise multi star guiding and whilst the guiding appeared better, SGP failed to complete downloading any main images. I rolled back to the stable (non dev) version of PhD2 and all worked again. Has anyone else had this experience. Will raise a separate topic with logs if I’m not doing something numpty.
For reference after completing a the first 600s exposure, it said downloading and just never moved on.

I am having the same intermittent issue with the PHD multi-star guider taking a long time (10 minutes) to settle below .5 in SGP, even though the guide graph looks very stable and .2 pixel RMS. The multi-star guiding is a big help for my Rainbow Astro RST-135 mount as I need to use 1 second exposures and multi-star seems to reduce the seeing variation.