PHD stops and will not resume during autofocus

This is a new issue for me. I have both OAGs and a guidescope so I know about the “pause guiding during autofocus” option and this is not that. I am currently using my guidescope. When running a sequence, after “center and rotate”, the autoguiding is resumed and starts. SGP waits to confirm this and then starts the autofocus. This worked flawlessly with me for years. For my guidescope, I have the option to “pause autoguiding during focus” unchecked in the equipment profile, but for my OAG equipment profile, it is checked. Both were working correctly. Last night, I was running with my guide scope. When the autofocus would start, PHD was operating fine. At some point in the autofocus, PHD would just stop. It would simply not update the next point on the guiding graph. It was not hung up. I could do anything with it including stopping guiding, but It would not register then next guiding point. SGP would be sitting there “waiting for autoguiding to settle”. After a while it would time out and abort the sequence. I check the equipment profile and reapplied the profile to the sequence with no effect. SGP would repeatedly do the same thing. I eventually had to turn off autofocus and the sequence would run. Obviously not ideal. It is as if, it is acting like the “pause autoguiding during focus” was checked, but when I use that with my OAG, PHD show a “PAUSED” on the guiding graph and then that goes away when the autofocus is finished, reaquires the guide star and starts running again. I have not tried running my guide scope this way because it should not need this. This is more like SGP issue some command to stop PHD2 but did not issue the command to resume since it thinks that the guiding is not paused. Tonight I will try running with the “pause autoguiding during focus” checked and see if that works, but something is wrong here. I have checked everything I can think of and am out of options. Please help.

I have spent a bunch more time trying to solve this. I still have the same issue. I have tried both setting for “Pause guiding during autofocus” both checked and unchecked and reapplied to equipment profile to the sequence each time. I have the same issue with PHD stopping. Its like SGP has paused the guiding, but is not sending the resume guiding. I really need help here.

I have no idea, but do you have a log with this problem?
Total shot in the dark… One thought that comes to mind is that perhaps your guide camera is momentarily losing connection to the computer. Any other flaky things happening that would point to a USB communication problem?

Also, I am using all USB3.0 powered hubs for the connections and have used the same setup for about a year. It is very reproducable. Also, without Autofocus running, I have no issues running the guide camera and download full images. This only happens with auto focus. However, if this is the case, is there any sort of delay setting I can try?

This is really odd…PHD2 is guiding…SGP appears to issue no commands to PHD2 and it stops guiding and goes into a Selected state. We then send the command to start guiding but didn’t it either isn’t received or something happens. It’s odd that you can reproduce this with just running Auto Focus.

[08/25/19 20:41:10.917][DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Guiding
[08/25/19 20:41:10.917][DEBUG] [Sequence Thread] Sending to PHD2:
{"method": "get_app_state", "id": 1001}

[08/25/19 20:41:11.018][DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Selected
[08/25/19 20:41:11.018][DEBUG] [Sequence Thread] PHD2: Requested unpause, but PHD2 reports it is not in a paused state
[08/25/19 20:41:11.018][DEBUG] [Sequence Thread] EventMarker 171 - t:NGC 6823 (0); e:0; f:58; o:
[08/25/19 20:41:11.018][DEBUG] [Sequence Thread] {"method": "guide", "params": [{"pixels": 1.5, "time": 5, "timeout": 600}, false ], "id": 1003}
[08/25/19 20:41:11.018][DEBUG] [Sequence Thread] Sending to PHD2:
{"method": "guide", "params": [{"pixels": 1.5, "time": 5, "timeout": 600}, false ], "id": 1003}

[08/25/19 20:41:11.018][DEBUG] [Sequence Thread] EventMarker 172 - t:NGC 6823 (0); e:0; f:58; o:
[08/25/19 20:41:11.018][DEBUG] [Sequence Thread] Checking PHD2 state...
[08/25/19 20:41:11.018][DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Selected
[08/25/19 20:41:11.018][DEBUG] [Sequence Thread] Sending to PHD2:
{"method": "get_app_state", "id": 1001}

Well I check the USB setting and that was different than usually. The ASI1600MM-C was at max USB speed. I am run new tests. Previously I as even able to get PHD to get stuck by manually running auto focus. Now I have run it manually twice will no issues. I will keep testing.

Well that did not work. I re-enabled autofocus and ran the sequence. PHD stopped again during autofocus. I still need help.

OK. Autofocus completed and PHD resumed. I will upload the log file. I will keep testing, but it looks like it may be this USB setting in the camera. I will keep you posted.

Just ran automatic meridian flip with autofocus enabled and everything is working. I will update again after I am sure that this fixed it. Thanks for the quick response and guess!!!

My sequence ran all night without a hitch including autofocus. Tonight, I will be adding 2nd target with different filter combinations that is about as stringent a test as I can come up with. If that passes, then it is clear that I had my first case of USB communication issues. To be clear, my ASI1600MM-COOL camera was set to a USB setting of 80 and the guide scope camera, an ASI174MM-mini, was set to a USB setting of 40. Both are connected with 100% USB3.0 connections through powered USB3.0 hubs. I am wondering if I can cause the issue again by going back to the 80/40 miss-match and if 80/80 would be free of the issue. Easy to test. However, I will try getting data tonight since those sort of tests are for the full moon!..

That’s good to hear. Hopefully the USB speed thing was the issue.

I’ve found that anything over 49 (even on a single camera) causes the USB to freeze up. YMMV, and I’d be interested to hear. Honestly…I don’t even know why this setting exists. It seems to be a large source of problems :man_shrugging:


Powered USB hubs are often the root of this kind of problem. I gave up on them years ago after isolating mysterious USB related problems. I had tried 3 or 4 different 3.0 hubs. Now all my USB devices connect directly to a USB port directly on the pc. I had to move the pc much closer to the mount so my cables would be no more than 10 feet long. I now run two USB 3.0 cameras (ASI1600, ASI183) on my dual scope rig, both running at 90%. No problems whatsoever.
Software Bisque recommends not using hubs for this reason.

This problem is mostly due to Sequence Completion.
For instance, if you run and complete a sequence and have instructed SGPro to park etc, and also have it disconnect the guide camera, this is where the problems is.
If you then load and run the new sequence, when SGPro communicate with PHD to calibrate, SGPro will wait for PHD to instruct SGPro to continue.
However, This won’t happen because the Guide camera has been disconnected from the previous Sequence completion. So, SGPro assume that the Guide Camera is still connected and never rechecks if this is the case, so just sits there doing nothing waiting for PHD command which will never happen.

SGPro needs to check if the camera is connected or not.