PHD2 Guiding Issues and Camera Naming Question

Last night I was having problems getting PHD2 to work with SGPRO sequences. I read through the forums and it looks like this has been a problem in the past, but I wanted to check to see if anyone else is having issues.

When I start a sequence, PHD2 launches, then the plate solving runs. Once the platesolving is done, SGP gets stuck with the message “resuming autoguider”. In the PHD2 graph, I can see the guider is running, but nothing happens in the sequence and I have to abort. I tried starting it manually, which has worked for me in the past, but nothing I did seemed to work last night so I had to disable autoguiding to get my sequence to run. PHD2 and SGP are up-to-date. Soooo…I have a few questions:

Any suggestions on what to try next?
One thing I noticed is that SGP said the default camera profile was invalid - I think I’ve corrected that, but not sure.

I also wonder if there is a way to force SGP/ASCOM to display the correct camera name? I have several ZWO cameras, and they appear as “ASI Camera (x)” in the dropdowns, which is really annoying as it messes up my file naming. I think this might have been the problem that caused the invalid profile also.


1 Like

Unfortunately no. The ASCOM drivers are generic so any of your cameras can connect through any of the numbered drivers. ZWO would need to release a driver that was specific for their camera so that the names would match. I don’t really seem them going this route.

You can try some of the buttons on the Autoguiding tab of the Control Panel to force a reconnect to PHD2. For instance you can try Stopping from SGP and then Resuming from SGP. This will typically force a reconnect if SGP is having issues talking to PHD2 or if we’re waiting for a callback from PHD2 but aren’t receiving it.


@Jared , @ChromeSurfer Renaming ZWO Camera 1 Camera 2 for ASCOM, the easiest way is to under the start menu, scroll to ASCOM, then select “Profile Explorer.” It resembles the system registry. (see the screenshots). Select the Camera Drivers. BE sure to select the right Camera 1 or 2 for the camera you are naming, select that camera. On the right, first line is Default. Just type in the name of what you want your camera named. Close profile explorer, open up any app that you can select your ASCOM camera (SGP PHD etc) and the new names will be there for easy ID. I also changed the FW name also! Again see screen caps. You will NEED to go under Equipment Profiles and change your camera to the new name. Otherwise it will be listed as “No Camera”

Name Change
Equip Send

1 Like

Thanks @Bos ! I saw those settings before, but I was tentative to change them because I thought it might mess something up.

Another disappointing night with PHD2 & SGP. Same problems. SGP runs the sequence, and gets stuck “resuming autoguider”, even though the graph is updating. I think my only option is to run PHD2 independently and tell SGP I have no autoguider for the profile.

I sometimes have similar issues - but it is usually my fault - PHD2 and SGP usually play together just fine if you ONLY allow SGP to handle PHD2. If you interfere with PHD2 directly, it is quite easy to get the two out of sync and both waiting on the other. The other common mistake is to set a too small settle value.

I had the same problem a few months ago. It started out of no where and ruined about a week’s imaging around a new moon. Very frustrating with so few clear nights here this year! I still have the issue if I disconnect then reconnect everything. I have been able to work around this by unplugging my guide camera (ASI174MM Mini and my imaging camera is an ASI1600MMc Pro) then I connect everything, then plug in the autoguider camera and connect it. If I leave things connected from one night to the next, it works fine but if I disconnect the cameras, I have to repeat this. The problem usually happens to me after a successful connection, frame and focus and plate solving. When I start the autoguider, SPG would change the guidecam to my imaging cam and not be able to find the main camera anymore. Then it would wait indefinitely for the autoguider to download a frame. I hope this helps.

I too have intermittent phd stuck on downloading. I havent tried your method, however the only downside is that cooling the camera for 6 to 8 minutes (1600mm) and then when phd gets stuck having to warm the camera for a period of time, disconnect by unplugging, replugging it back in, cooling the camera for another 6 to 8 minutes and not be sure that is even going to work is frustrating. It should not be that difficult for the two (phd and sgp) to play nice together.


I don’t need to cool, warm and recool. I just establish connection with the 1600 first then connect the 174.

I’m using the same parameters that worked (mostly) for me before and my mount and camera are the same. I think I might downgrade SGP if running separately doesn’t fix the issue. Just waiting for clear skies here in Ohio.

I agree, people seem to have been dancing around this issue for a while. It would be nice if it was reliable.


just a thought - could this be associated with the USB throttling control. I can cause the same issues with my QHY camera set if I set the USB traffic control too low.

Is the throttle in SGP? I don’t know what I’m currently setup as, but it’s probably defaults since I’ve not seen the setting to modify it.

Thanks Bos, That’s great - I did try to edit the names once but then things stopped working. I’ll try again and this time edit the equipment profile within SGP too.
I have 4 ASI cameras though (a 2600MCP - with a 5x2" filter wheel, a 290 mm mini for guiding, another 290 mm for planetary and also 120 mm for guiding) . Do you know if I can set up additional drivers for the 290 mm and its filter wheel? Not all are connected at the same time of course so it may not be necessary but it would simplify things if I could. Thanks… John

I found the throttle for the USB, it’s set at the default (40%), so that doesn’t appear to be the problem either. I noticed a new thread started on this issue and saw some comments that some are rolling back to earlier SGP versions to get it to work. Maybe that’s the only solution until this gets fixed?