PHD2 Path not set

I hope that this is the right place to ask!

Im setting up a Mesu 200 to use with SGP. When I connect to my equipment (without PHD2 running) I get an error message telling me that the PHD2 path is not valid. If I have PHD2 running when connecting equipment I get an error saying “PHD Profile “No Profile Selected” is not valid”.

I cant find anywhere to enter the PHD install path?

SGP logfile:

Your log indicates that you are asking PHD2 to start automatically, but have not told SGPro where it is located or what profile to use. You can set these values in the control panel->auto guider. Select PHD2, click “Settings”.

Thanks Ken,

I must be going nuts, but I can’t see a “Settings” button in AutoGuise in the control panel?

PHD2 by Stephen Jennette, on Flickr

Any ideas?

Ah… yes, you are experiencing a bug in 2.4.2. Please upgrade to the beta 2.4.3 (it is quite stable at this point) and you will find this issue fixed (or at least you will find the settings button where it should be so you can fix it).

1 Like

You are using which I am sure I read a thread here about someone with a similar problem and the code for the PHD2 autostart meant to being hidden but was not under some circumstances.

What I would do is go to the current SGP beta and the Dev5 release of PHD2.

Settings button will then be there, will allow you to continue.

I have been using the latest beta and and PHD2 dev5 release for the past few nights and had not issues.

1 Like

Thanks both. I’ll download the beta.

Thanks for your help guys.

Ive downlaoded and installed the beta and have gotten my Auto Guide settings back :smiley:

One other small problem…I now get a pop error message “Timeout! Could not refresh PHD Profiles” The profile dropdown remains empty. Is this PHD error or a SGP error?

Yes… the PHD2 version checker is also a little broken. PHD2 2.5.0 will not work with the SGPro 2.4.3 beta. You will need to download and install PHD2 2.5.0 dev 5 (dont forget to point SGPro to this version).

Hmmm…Im never too comfortable having lots of beta software installed…

However, it seems to have solved the problem, so thank you!

It’s up to you… both a very close to release.