Plate Solve 2 when far off target

PlateSolve2 works great and is very fast, when it works.

It seems that if you are too far off target it never completes (or get impatient and abort) but If I blind solve the same frame with it solves quickly, and I can use that to solve sync slew repeat to bring it closer to the target and then get platesolve2 working again.

Any suggested settings to make PlateSolve2 work better at greater goto error distances. I’d be willing to sacrifice some speed.

I’m using all default settings now.

I gave up on PS2 with my 8 inch…astrometry works fine. PS2 works better with my wide field scope

There is no trick to getting PS2 to solve when you are too far from the target. I have noticed that it if fails to solve within 100 regions or so, it will not solve at all. So, I have limited it to 100 regions and have set up ANSVR as the blind solve failover. That way, I don’t waste time with PS2 trying to solve 1000 regions when it is destined to fail.


In a simple test of PlateSolve 2, I used an image with a precisely known RA/DEC center point. I then began adjusting the “hint” given to PS2 to have increasingly large errors. Somewhere around 15 arc minutes of error, PS2 started showing problems solving. By 20 arc minutes of error, PS2 would always fail. The same test run with PinPoint, showed PinPoint failing around 12 arc minutes of error. This will probably vary with FOV and image scale.

A mount with a good polar alignment and good orthogonality, should always slew to the target with less than 5 arc minutes of error. I use ANSVR as the blind fail over, which works quite well as long as you have the proper indexes downloaded.

My start up routine is to manually slew the scope to a point near the zenith and perform a “solve and sync” that sometimes fails over to ANSVR. The rest of the night, PS2 always solves immediately.


Thanks to all for the tips. I have configured ANSVR as the blind failover
and limited Platesolve2 to 100 search regions and will test when the
weather clears.

@Charlie, I don’t really know if my problem was “too far off” or not. I
only know that Platesolve2 failed to solve and did. I can go
back and check however. I have a mid level mount (EQ8) semi permanently
mounted and Polar Aligned with PoleMaster. Platesolve2 was working on the
opposite side of the meridian but failing close to the tree line on the
west side. Before platesolve2 I was using ANSVR without issues on the same

just as a data point i have seen PS2 mysteriously fail to solve fields - even after solving the initial (wrong pointing) frame, it sometimes fails on the next frame where the pointing is 99% correct.

certain fields seem susceptible to this - around the veil nebula for example - so maybe there’s an issue when there are “too many” stars.


How do you limit the fields to be tried in PS2?

I keep putting 100 in but it doesn’t stick and now It’s saying 3000 instead of the original 900.

I always do my first plate solve for each session with the blind solve. Thereafter ps2 always solves without issue for me.

Just like you are doing, but we did not take the time to make the search regions “stick” for PS2 because it’s honestly not that important. Higher numbers essentially set how long a solve can take, but will not make it any faster or slower. The old max of 999, was inaccurate and we have plugged in better values (always defaulting to the high for maximum sequence resiliency).

Perhaps you might consider having two default search region values. 3000 is fine if PS2 is the only solver but if the user has a backup solver something like 49 would be a better number because you want it to fail quickly if it does not solve within a few regions.

I second DesrtSky’s option.

I use PS2 with a local copy on another pc on my network of as a fallback. I set PS2 to 100 regions, but it keeps changing to 999 (or max regions). I’d rather it stick to my 100 or less and fallback than to take up a lot of time crunching through 1000 regions. PS2 is much faster than a blind solve for when I am close, but in dense star fields, takes a lot of time if it needs to do a large spiral search (my imaging pc is a rather old slow notebook). I also notice that sometimes PS2 will miss a solve for some reason and continue to spiral search. If I’m near the pc when PS2 is doing a large spiral, I’ll usually abort it and let the solving fallback to my blind solve, but a 2 am, I’m usually not at the pc to stop these and can lose a bit of imaging time.

Frank Z…

OK… we can take a look at persisting search options to sequence saves.

OK, I think I actually may need some guidance here. I reviewed the code around here and it looks to me like I already made the effort to save search regions to the sequence at some time. The code to make it stick is there and the value is being saved to profiles and sequences.

What series of steps are you seeing where this value is lost?


It doesn’t seem real consistent, but when I first start up for the night, I’ll do a quick focus, then a plate solve to set my position. I notice that if I use the blind solve or abort the PS2 solve to fallback to a blind solve, the next time PS2 runs the regions are set to 999 instead of my default of 100.

Frank Z…

OK, thanks. I will try to reproduce in a bit. If anyone else has any guidance for reproducing this issue, it is appreciated.