Plate solve error, not centering

Hello, first of all thank you for your dedication to this wonderful program.
I´ve been using SGP for years and for a few months when i do a plate solve, it´s not able to center the target, I had to try 30 times and 10 times more for recovery sequence to get it done, before it was the first or second try.

The rotator does its job, everithing Works fine, the parameters have never been change, and i find this error. Last night apart from that error, it did not download the image of the plate solve, and the program hung, causing the remote roof to close, and luckily it did not crash with the telescope.
Ineed some guidance on where the error is in the plate solve, it does not plate solve until after 30 atempts. I can send other logs that there is only this problema.

I hope i have informed you well.
Thank you very much.

Link to Logs

Approx time of issue: 23:30

Useful Info

OS: Microsoft Windows 10 Pro
Ver: (32-bit)
.NET: 4.8

EQMOD can be tricky to get working right. I am no expert with it and have never used it, but, looking at the logs, two things stand out as issues to me.

First, I have never seen this before, but EQMOD seems to be reporting that it is using an unsupported equatorial reference system. SGPro supports only J2000 and JNow. Your scope is reporting “other” and SGPro will use J2000.

[11/17/22 22:27:25.193][DEBUG][Telescope Thread][NONE] WARNING! Telescope equatorial system equOther, not supported.  Defaulting J2000...

Second, and the likely the root of the issue, the driver seems to have picked up a setting that disallows external sync from an application like SGPro. Because of this, SGPro is never able to tell your mount where it’s pointing (after a successful solve). This will, of course, create a situation where you will never converge on the target. Alternatively, if you have configured EQMOD purposely not to accept external syncs because you prefer to use an external pointing model, then you will need to choose one of the “offset” options for the telescope sync behavior.

[11/17/22 23:46:47.403][DEBUG][Telescope Thread][SQ;MF;CE;] ASCOM Telescope: Invalid Operation Exception in Sync : SyncToTarget() RaDec sync was rejected. (System.Reflection.TargetInvocationException: Se produjo una excepción en el destino de la invocación. ---> System.Runtime.InteropServices.COMException: SyncToTarget() RaDec sync was rejected.

I don’t know if this will solve your issue and I actually don’t even know if it’s accurate in 2022, but, due to the complexity of EQMOD, we do have specific guidance for using it with SGPro here:

Documentation on telescope sync behavior:

Hi Ken, thanks for your reply.
As soon as I saw the word J2000 I went directly to EqMOD and it was in another option, so I changed it to J2000, I did the test, and I had the same error, there was no way to center the image after the plate solve.
So I had to log out and wait for a while.
Now I have to try uncheck the EQmod option of Allow automeridian flip.
The strange thing is that after many years, I have never touched those options and suddenly it doesn’t work to center after plate solve. I’ll try to test tonight if time permits. If I see the same error, I’ll tell you.
Thank you very much Ken.

Hi Ken… Well after to do all yous instructions, was imposible centering after meridian flip. All instruccions are 100%.
I send you the last log in case you are able to discover the error. The limits of the mount are ok. I do not know what to do.
The error begins arround 20:30.
thank you so much.

Link to Logs

Approx time of issue: 20:32

Useful Info

OS: Microsoft Windows 10 Pro
Ver: (32-bit)
.NET: 4.8

You may need to get help from somebody that has more experience with EQMOD (or the EQMOD forum may be a good resource). All of your settings, except for one, look good and it is my belief that you are close to success. The issue, is still that your EQMOD driver is configured in such a way that it does not allow for external sync from an app like SGPro:

[11/26/22 20:42:07.627][DEBUG][Telescope Thread][SQ;MF;CE;] ASCOM Telescope: Invalid Operation Exception in Sync : SyncToTarget() RaDec sync was rejected.

To me, it seems as though you should be good to go once you have cleared and disabled the EQMOD modeling data, but I am not certain.

I’ll investigate then. Thank you very much for everything Ken.

You have cleared all sync points and have eqmod in dialog mode, correct?


Yes, all erased and dialog mode.
The limits of the mount have a margin.
Tonight I changed the plate software, I used planewave’s platesolve, and once the change of meridian was done, the program found 6 objects, but it kept centering without changes in the mount, always in the same place, until after about 30 attempts that finally end he was able to center well, and follow the sequence. Something that before with 2 attempts was already fine.