Plate Solving Chain - changing order

Have been checking out the Plate Solve Chain function. Encountered an anomaly which might be something specific to my workstation setup/config/funkiness (Windows 11, multi-display RDP’ing into Windows 10 obsy PC) and not SGP itself, but thought I would mention it anyway.

When re-ordering inside the Sequence/Control Panel (drag gripper or right-click pop-up), it seems to work ok. However, when trying to re-order in an Equipment Profile, the mouse-right-click does not result in a pop-up menu.

Also, when using the gripper icon with mouse-left-click (Sequence or Equip Profile), the pop-up window looks “funky” and far removed from the plate solve window. Example pics attached.



Oh, that’s weird. This is almost certainly an RDP issue. I may have to print some diagnostic info into the logs. Obviously, it’s supposed to be like this:


Thanks. This one is reproducible. Will take a look.

Oh! Also, can you check a thing on your machine using RDP? Drag and drop for targets uses a similar, but slightly different method than the chain solver. Could you drag and drop some targets around and tell me if the overlay appears where it’s supposed to or if it appears with some kind of offset to the target list?

I’ve never tried this before. And I’m not sure how to do it? You are referring to targets (and not events)? Is there a gripper icon like there is in the plate solver chain list?

I don’t see anywhere where the mouse pointer changes to a hand grip icon. And I’ve tried left-click dragging in different places around the target list but the drag function does not kick in. I am probably missing something obvious - lol.


It is admittedly kind of hidden, but here is the button to make the grippers appear on the targets


OK - looks like similar result.


OK thx. Looks to be just the x dimension somehow. I’ll think about this one.

Just confirming that the x-dimension drift does not happen for me with using the obsy PC directly. Only when using RDP.

One more thing that may or may not be helpful on this … when mouse hovering over the icons (via RDP) at the bottom of the sequencer window, the same x-dimension drift to the right happens - for some icons but not others. Per example shown, it drifts for:

Drifts to the right for:

  • Add
  • Delete
  • Gripper
  • Settings

But displays normally for:

  • Move Up arrow
  • Move Down arrow


Thx for the info. With respect to your RDP setup, does the local computer have multiple monitors by chance? If it does, does it seem like the offset may be offset by the size of the other monitor (I guess if it were smaller maybe?). This is all unlikely… just totally and completely unsure how that offset is introduced over RDP.

Yes - local PC has 3 monitors. The left monitor is 2K and the others are 4K. SGP main window is on the middle screen and I often drag Sequencer/Control windows to the right (also 4K) monitor.

Given that the left (2K) monitor is half the pixels wide and that the drift-to-the-right is about half a screen wide, I would say the answer to your question is yes!

Another observation I’ve been noticing for some time is that when I open the Control Panel, it is also often “drifted” to the right. Sometimes it is mostly “off screen” and sometimes it is off screen totally (and I have to use the “Reset placement of the Control Panel window”.

Hope this helps.


1 Like