Plate Solving does not pass RA/DEC hints to local Astrometry server

I have been trying out SGPro in the house to get a feel for it before I take it out and attach it to the scope (because trying to get to grips with new software in the dark and the cold is never fun). One of the things I am trying to do is to set up plate solving. I have successfully installed ANSVR and configured SGPro to talk to it, however I was trying to figure out what it was so slow, much slower than the equivalent solve for AstroTortilla (which uses the same back end).

Looking through the logs, even if I give the RA and DEC hints, they are not passed to ANSVR.

As a test I opened a CR2 image of a previous attempt at imaging the Rosette Nebula as an Open->Image. Then right clicked on the image and selected Plate Solve. I entered:

When I selected “Solve”, I get the following in the ANSVR log:

[2015-02-25 21:59:52] [Connect from]
[2015-02-25 21:59:52] POST /api/login HTTP/1.1
[2015-02-25 21:59:52] POST /api/upload/ HTTP/1.1
[2015-02-25 21:59:52] request_json is: {“session”:“12”,“allow_commercial_use”:“d”,“allow_modifications”:“d”,“publicly_visible”:“y”,“scale_units”:“arcsecperpix”,“scale_type”:“ev”,“scale_est”:7.49955,“scale_err”:5.0}
[2015-02-25 21:59:52] UPLOAD: session is 12
[2015-02-25 21:59:53] POST /api/submissions/12 HTTP/1.1
scale_args: -u arcsecperpix -L 7.1245725 -H 7.8745275
UPLOAD: /opt/ansvr/run_solver 480 /usr/bin/solve-field -p -O -U none -B none -R none -M none -N none -C cancel --crpix-center -z 2 --sigma 50 --objs 100 -c0.02 -u arcsecperpix -L 7.1245725 -H 7.8745275
Using timeout = 480
exec /usr/bin/solve-field -p -O -U none -B none -R none -M none -N none -C cancel --crpix-center -z 2 --sigma 50 --objs 100 -c0.02 -u arcsecperpix -L 7.1245725 -H 7.8745275
Reading input file 1 of 1: “”…
[2015-02-25 21:59:53] SUBS: solve is not done yet
[2015-02-25 21:59:53] SUBS: jstr: {“jobs”:[],“processing_started”:“0”,“user”:“0”,“user_images”:[],“processing_finished”:“0”}
[2015-02-25 21:59:54] POST /api/submissions/12 HTTP/1.1

As it does not send the “–ra”, “–dec” and “–radius” fields, it still performs a whole sky search. The search completes, but it takes 250 seconds.

If I start up a bash shell and run the same command from the command line, but add the --ra, --dec and --radius commands, it solves it in 4 seconds.

I can understand if I had selected the “Blind Solve”, but I would have expected “Solve” to honour the hints in the window. Is this expected behaviour? and if not, can anyone point out what I need to do in order to pass the hints to ANSVR?

When trying to centre the scope as part of an actual capture routine, are the RA and DEC parameters passed to ANSVR?

Is this with 2.3 or 2.4 beta 15? Do you get the same behaviour when trying a Solve from the Target Setting dialog box?

I’ll try this out later and see if I see the same (with 2.4 beta 15).


This is correct. For we don’t currently pass RA/Dec hints as we found that it made no real difference when sending things to the nova web service. Not only that but it was problematic if an incorrect RA/Dec was sent in.

However I can see the benefit to this as well. The nova service can currently take RA/Dec hints but I’m not sure if ANSVR can take them at the moment. I’ll play around with it this evening and see.



That’s right, ansvr does not currently accept the ra/dec/radius hints. I will send you a version to test with that accepts the hints.



This is with 2.4b15, but as Jared and Andy have indicated it is behaviour as designed at the moment. It is just a little confusing as a user, because there is nothing to indicate that the hints are being ignored or not depending on which plate solver you have selected.

I managed to get the scope running tonight with SGPro for the first time, unfortuntely it was a disappointing experience. I did manage to figure out the right combination of settings and data files in ansvr to get plate solves down to 3 minutes (which is pretty good for a 9 year old Centrino). However I kept coming across other issues.

  • As the gods of the Wifi decided to give me coverage in the garden tonight, I tried to to use the Nova server instead of my laptop for plate solves, however this would not work because the file that was saved from the camera had a filename like “plate_solved.fits”, but the file it tried to upload to Nova had a file name something like “” so it failed. Unfortunately without looking in the log file there was no way to determine why the failure occured.

  • The software does not seem to perform any kind of keep-alive on the camera. I would conect the camera, then set up the sequence, but by the time I came to plate solve the sequence the camera would have gone to sleep due to inactivity. I would need to power cycle the camera to get Windows to recognise it again. I am not sure what BackyardEOS does, but once it gets hold of the camera it never seems to let it drop off again.

  • There was something about my setup that SGPro just does not play nicely with. I never managed to get a sequence started as at some point during the centering at the start of the sequence it would inform me that it had failed to centre the scope. I would check and the Acsom intrface would show that it had lost the connection to the mount. The really bizare thing is that it was because the powered USB hub that the mount and the guide camera are connected to had disappeard from Windows. Even more bizare was that if I unplugged the usb cable from the hub to the laptop and plugged it back in again, the laptop would BSOD. I can not believe that this is anything to do with SGPro directly, but I managed to achieve this 3 times in a row. As an experiment I went back to Astrotortilla and BackyardEOS, and it is all working fine.

It is a real shame, as I love the concept of the software. I love that it will take a file from a previous session and use it as the target for the curent session. I love the file management and the centing on multiple targets over an evening. It just wont play nicely with my kit. I am debating taking the other laptop out the next night it is clear and trying it on a higher speced machine to see if it behaves any better (I use an old cf29 Toughbook outside as it is pretty much indestructable and does not mind getting covered in frost or dew, and then an 8gb i7 for processing the images afterwards)

I found it much easier to start using SGP by following Alex’s excellent tutorial. You don’y have to take a week but his step by step approach isolated PC problems etc.

I also found the videos on the following site useful:

These were created by ‘buzz’ I believe, a regular contributor on this forum.