PlateSolve 2 and different pixel ratios

I am running two rigs simultaneously on the same machine (don’t worry, the drivers are all different!). Everything is working actually pretty well.

When SGP calls PlateSolve2, it passes the FOV over to it based on the camera and telescope settings you set in the Control Panel. That all works great.

However, it does not seem to pass the pixel ratio (“Default Aspect Ratio (Y/X)” in PS2). Now, for most cameras, the pixels are square. One of my two rigs has square pixels (so a ratio of 1). My other camera, however, is an Orion Starshoot, which has pixels of size 8.3x8.6 microns, so a pixel ratio of 0.965.

Now, when I set this ratio manually in PlateSolve2, it solves my Starshoot images just fine. But since I’m running two rigs at once, I can’t set two different values for it.

Does anyone know if it’s possible to set this somewhere in SGP so it can pass it to PlateSolve2? Or if not, can I request this as a feature to be added? The pixel sizes are stored in the FITS header, so the ratio would be easy to calculate and pass to PlateSolve2 the same way the FOV is passed.

It doesn’t look like this is possible to send via the Command Line for PS2.

Alternatively you may want to also checkout ASTAP.

Thanks,
Jared

Darn. I will check it out, thanks!

-AstronoMolly

As a note for future readers – I couldn’t get ASTAP to work with my Orion Starshoot Deep Space Monochrome Imager II because the frame size is too small (it requires at least 1280x960), but it is working well with my other camera (ZWO ASI1600MM Pro), so I’m using ASTAP with the ZWO and PlateSolve2 the Starshoot.

I will also add that ASTAP is FAST!

Thanks for the follow up. @han any suggestions here?

Thanks,
Jared

Mollycule,

The 1280 x 960 pixels is not an hard limit. Only reliability goes down. Best would be if you could provide a test image of the Orion Starshoot camera ( 752 x 582 pixels ?), so I can have a look. If the image quality is good and FOV is not too small, solving will work.

Could you upload one or more Starshoot test images to http://nova.astrometry.net/ and provide the link(s)?

Han

That might be true, but when I fed it some images to test, ASTAP said they were too small. Since my FOV is 27x21 arcmin, I also tried installing the <20 arcmin library, but I got the same error.
Here’s an example image solved on astrometry.net: http://nova.astrometry.net/user_images/3796466#annotated

Thanks for the image. I have experimented a little with the image. I could not get it solve either.

After I annotated the image with the database stars. Some stars shouldn’t be there. I marked them blue. The should be fainter but look bright. The Gaia star database has no errors, so they are either ghost stars or camera response is weird. Anyhow this will confuse the solver. Maybe it could be fixed (automatic) with a dark but probably it will never be reliable. So interesting to investigate but this camera you better use PS2 or astrometry.net.

new-image

Han

Interesting, that’s very strange!
It does solve no problem in PlateSolve2 (most of the time). The camera has a few other glitches as well (sometimes I get blank frames), so I’ll probably eventually replace it (just using something I got for free from someone), but it has been really interesting to use. It’s got a true 16-bit ADC, much larger well depth than my CMOS cameras, and pretty high sensitivity thanks to those big juicy pixels. I don’t care much about extra noise and stuff because I’m using it for variable star observing and not pretty pictures. But stars appearing brighter than they should is a concern for doing reliable variable star observing. I’ll have to look into it.

Thanks!