PlateSolve2 File Dialog

OK, so this is weird.

I have two laptops running SG Pro, one goes into the observatory to connect to the equipment and the other to use for testing and to control the first one over the LAN. I am trying to learn which is the better plate solving tool (PlateSolve2 or ASTAP) so I have been testing both on some recent images I have taken in the last month or so.

The observatory laptop is a Dell Inspiron 14" 5000 2-in-1 (i7 8GB) while the monitoring and control laptop is an ASUS 17" GL753VE (i7 16GB) , both running the identical same version of Windows 10 version 2004, with the latest updates as of today (4/22/2021). Both are showing .NET Framework 4.8 installed and both are running SGPro v3.2.0.660.

On the observatory laptop, using either the Equipment Profile Manager or the Control Panel Plate Solve tab, the PlateSolve 2.29 window will not open a Windows File Dialog using either the File Open option nor the Focus Analysis option. It just flashes with no other effects.

The weird thing is that if I run the PlateSolve2.exe found in the SequenceGenerator folder spearately from SGPro, it works fine. It only fails to open the Windows File Dialog if it runs PlateSolve2.exe from within SGPro. Not sure if it works during a sequence run as I have not tried that. Everything works fine when I run SGPro from the ASUS laptop, but that is not the laptop I connect to the equipment with.

Since I am a retired software engineer, I tried everything I could think of, including swapping out PlateSolve2 exe’s, . dll’s and ocx’s. No luck.

Thanks in advance for any other suggestions.


I am running SGPro V4.0.0.661 and PlateSolve 2.29 from within SGPro. It doesn’t always result in a good plate solve, but it does on the order of 9 out of 10 times.

I do not know if the .661 build is the same for v3 or v4.

My advice is that you don’t waste your time on testing PS2 vs ASTAP, ASTAP will most likely win since most people have switched from PS2 to ASTAP and found it works better, solves faster and has a smaller chance of failing on a difficult image.

Personally i made the switch even before ASTAP was an official choice in SGP and never looked back.
I also use ASTAP when modelling with 10 Micron mount :+1:

1 Like

Maybe I am doing something wrong or have something misconfigured, but I ran 4 of my latest object images (M51, NGC3628, IC405 and NGC4565) through PS2, ASTAP and AstroTortilla (all outside of SGPro). ASTAP was only able to solve the NGC4565 image, while all 4 were solved with PS2 and AstroTortilla. But that is a subject for a different thread.

The File Dialog problem seems to have something to do with how PlateSolve2.exe is being called by SGPro (possibly a setting in ProcessStartInfo?) and some unexpected Windows handling of that call on the Dell laptop. I’ve also seen EQASCOM threads in where there are issues with Windows 10 version 2004 with certain ActiveX controls that won’t display and wonder if there is any relation to this issue. BTW, I’ve also tried running SGPro as administrator with the same result.

I wrote a quick C# console exe that runs PS2 using Process.Start to eliminate SGPro being part of the equation, but it works fine when called from that exe. I’ll keep troubleshooting it.

Thanks again.

ASTAP gets my vote , very FAST , solves in a few seconds !!

Regards Trev

You will probably have to adjust the binning in ASTAP to get it to solve your images, ASTAP doesn’t like images being too large or too small so it has an option where you can adjust the binning to create better fitting image.