Possible corrupted sequence file (.sgf) recovery?

I’m using SGP and have done for a few years quite happily. I know I could upgrade to V4 but I won’t until proper dual scope supprot is available.

I was setting up to run some flats today and my previous sequence which opens when SGP runs was there no problem.

The flats calibration wizard asks to start a new sequence, which is fine.

I did that, and have run my flats sequence.

Herein lies my problem - my previously open sequence now won’t open, I get the message:

'Error loading sequence c:\Users\etc\etc\etc.sgf.
Error setting value to ‘ImageData’ on ‘SequenceGenerator.SequenceFile’.

In the log I get this:

[12/17/22 19:55:52.318][DEBUG][Main Thread][NONE] Error opening sequence. Unable to deserialize C:\Users\Jon\Desktop\SGP Captures\December targets.sgf

The log doesn’t show anything else to help.

Other .sgf files open fine, it’s just the one I need that won’t.

I’ve compared the .sgf file in notepad++ to other working .sgf files and can’t see much in the way of any differences or weird things that don’t look right.

I’ve saved the .sgf from notepad++ to a new .sgf file and SGP still won’t open it.

How can I recover the .sgf file? I have several targets in that sequence and don’t want to lose my framing especially.


Here’s the pop up message:


I also tried rebooting etc. no difference.

I have SGP on another PC for testing (same version) and that comes up with the same message when trying to open that particular .sgf file.

As they are just text files, have you tried opening it in notepad/notepad++ ??

Yes Dr, I’ve said that in my post!

If you want to make the sequence available for inspection, we can take a look at it.

Thanks Ken, file attached.
December targets.sgf (552.2 KB)

Hmm… It’s a mystery apparently. I was able to open that sequence with no issues in both 3.2 and 4.2

Ok, could you make a slight change (add 1 more sub anywhere for example) and attach it here, see if I can then open it please?