Probably a bug? Park not supported with rotate through events

Hello Folks,
SGP is giving me ‘Event park option is not supported when “Rotate through events” is selected.’, knowing that “Rotate through events” isn’t selected and no SGP settings were changed since the last time it was used.

All hardware are functioning properly, this issue appears upon pressing “Run Sequence”, after going through the regular workflow: Polar Alignment, Center on Target, Plate Solving, Frame and Focus, Guiding initiation
OS: Windows 10
.NetFramework: 4.8.03761

Status and debugging done that didn’t solve the problem:

  1. Enabled and disabled “Rotate through events” (from CP and EPM)
  2. Disabled and enabled “Park when sequence completes” (from CP, EPM), same for Pre-event and Post-event
  3. Rebooted
  4. Installed the latest SGP version
  5. Created a new event
  6. Disabled all other Targets and Events in the sequence
  7. Created a fresh sequence with a single target and event
  8. Tried multiple profiles
  9. Parked the scope (no issues at all)
  10. Error still occurring even when no hardware is connected

One of the remaining doubt is the last windows update, that might have probably updated .NetFramework to a higher version than the one supported by SGP.

Sorry for the long post, and thanks in advance


Doesn’t this make sense? If you are rotating through events (not targets) you would not want an interruption after one event has completed. Say you were doing 2 min subs of RGB, it would park the mount before it got started… but if you were not rotating through the events, it makes more sense I think for it to park when it has completed B.

It does but irrelevant to my case. The only difference is that only one target with a single event is enabled, where ‘Rotate through events’ is disabled.

In all cases, I think this issue is solved, will post the solution as soon as I confirm.

Well, if you have only one target and event… the solution is fairly easy. Do you realize that you can also park at sequence end? That may be more convenient.

Buzz, this issue is not a matter of parking or not parking the telescope as for this target and event in particular, rotation is NOT checked and the above error is preventing the sequence from starting. More information can be found in the original post.
(30 minutes separate us if this got solved)

ah, oops - I got the wrong end of the stick.

Do you have any other event options enabled?

There is also a way of re-setting SGP - if I recall correctly, a new installation does not reset these. There are some files, possibly stored in the appdata folder, which store the configuration. I will see if I can find the post from the developers.

Hi there,

I tried briefly to recreate this issue, but we must be doing something different.

We will need more information to be able to help. Please send us logs, SGPro and OS versions and we’ll take a look.

More information here How to Submit Logs in SGPro - SGPro Support - Main Sequence Software

Support requests go in this category #sequence-generator:sgpro-support

Thank you Buzz for the follow up, the problem is solved.

Ken, here is what solved it:
After a long debugging session with a friend, it seems like this peoblem originated from another target of the same sequence that had the “Rotate through events enabled”, even that the other target was disabled same all events. (all other targets and events from the same sequence were disabled too)

Not sure if this is a bug or a feature. If it were a feature, I think it’s not very intuitive.