Problem driver Pulsar2 with Windows 10 Pro

I raise the post.
I have problems of connection with Pulsar2 and the ASCOM driver. Pulsar2.telescope.dll version P.Cagas
However it works with the former ASCOM driver. Pulsar.Telescope.dll version 5.0.13 P Kitching.

I used Ascom diagnostics:
This is what I get with win 7

And what I get with win 8.
The driver does not load the values of RA, DEC, lat, long, time… This is what stops operating with TSX, sky map and maximDL software…
What configuration of driver do you have (driver pulsar, firmware…)
Is this a problem signing driver? I tried to disable the compulsory signature of the driver, but it has changed nothing.
I do the test with Pulsar Commander under win 10. The com port opens, the values of RA, DEC, lat, long and time are well displayed. The command with the hand controller works also.


It’s worth trying ASCOM Conform rather than the diagnostics.

But from what these screen shots show there’s a problem with the Pulsar driver that needs to be resolved by its author.

BTW those screen shots seem to show it’s OK for W7 and not OK for W10.


That is correct.
I tried with TSX or maximDL without result.