Problem starting "looping" PHD2 with SBIG using STi/OAG


I’m unable to get SGP working with my SBIG STF-8300M camera using the self-guided FW with OAG. I can get as far as:

  • SBIG camera successfully connected in SGP
  • PHD2 launched from SGP
  • PHD2 successfully connected to “SGP API Guider” camera

However, when I try to manually start “looping” in PHD2, I get the following error message:

“ASCOM error – Cannot start exposure with given parameters: (ASCOM.SGP_API_Guider.Camera) Device is not connected”


  1. It’s not clear to me what is the right guide camera option I should be setting in SGP camera settings - is the STi OAG considered “Internal”, “Remote guide head” or should it be set to “None”? I have tried all three options but get the same “device is not connected” error message regardless of the guider option that I set.

  2. Also, when I click on the “select camera” option for the SGP API Guider camera in PHD2, it only lists one device (“Camera 1”). Is this the STi or the main STF-8300?

  3. I assume I should be manually trying to start looping in PHD2 and not be leaving it for SGP to start?

And fyi: Guiding via PHD2 works fine when not using SGP and just connecting PHD2 directly to the SBIG camera driver, so this is not a problem with the camera/OAG set-up.

Any help would be greatly appreciated! :slight_smile:



Hmm, it has been ages since I had an STF (I am using STT now). If I am correct, the STi guide camera that is attached to the STF OAG attachment (which is not really a self-guide filter wheel like on the STT) does not connect to the STF but directly to the PC via USB (and optionally to the mount via the ST4 cable).

If that is the case, you do not use the SGP API at all. There is no setting for internal or external guide chip since the STF does not have one (use “none”). You simply select the STi as the guide camera directly in PhD.

Short version - you treat this like any other camera system that uses an OAG and guide camera.

Thank you for the response!

I just went back and switched PHD2 to using the SIBG driver directly and it connected and started looping without any issue! :slight_smile:

At some point in setting SGP up I had hit a connection failure connecting both SGP and PHD2 to the SBIG driver, and that led me down the path of thinking I needed to use the API Guider driver, but as you point out, that is not needed!

Ok - just need to wait 9 hours for darkness so I can try it out.

Many thanks!