Problem with beta and suggestion for Homing Mounts


I was just setting up my laptop with all of the current versions of all software and drivers as well as the latest beta and noticed something that is not a super big deal but has been a small issue. This is not just the beta, it has always done this.

If you have “home on connect” checked in TheSkyTelescope driver and your park position is a fair distance from the home position that (in my case a Paramount ME) must go to on startup, SGP will display an error before the mount is able to get to the home position. It might nice to either have this be a longer time to error or maybe user settable.

My solution has always been to home the mount in TheSky first since then it is at home already and does not need to do much so takes less than what I assume is a hard coded error out time.

As I say, not an operational show stopper by any means, but figured I would mention it.

I noticed this too with the MX and from then on just unconsciously connected and homed in TheSkyX before running SGP.

There is an advantage to our work-around though and to leave the ‘home on connect’ unchecked- if you close TSX or the ASCOM driver for whatever reason, as long as the mount remains powered, it will not do an unnecessary home command when you fire up the ASCOM connection again. I had a few instances where I needed to reboot the software (and occasionally the PC) and I could carry on without all that repeated slewing, centering, re-acquiring guide stars etc.

Agreed. I did run into something this morning while testing the beta for another issue (see thread on PhD crash).

I had, as you mentioned, started TSX, homed the mount there, then went on to connect to the mount in SGP (via the new TS driver). When I did it failed to connect and gave an error because it had tried to start (a second copy) of TSX.

If I did not have TSX running, it would start TSX when I asked it to connect and would connect just fine.

This creates a conflict since if you start TSX first and home the mount, you get the error when it tries to start the second copy. If you do NOT start TSX first, then you run into the time out error due to the time it takes the mount to slew to the home position. The only way to avoid both is to use TSX to home the mount first, then shut down TSX and let SGP start it again - a bit clunky.

Maybe there is a way around this in the new SGP, if so, what is it?

If you need logs, you will probably see the issue in the logs I was doing for the other PhD crash issue:


FYI, here are my settings for the driver:


I have met the disconnection issue with my MX a couple of times but more when i do an initial slew from the home position and put it down to a USB quirk.

It’s odd that SGP is trying to start a second SkyX, I start and connect PHD2 first, this starts SkyX which I flick to and home the mount. I then start SGP and connect the mount which does not try and start SkyX again.

Just tried a few permeations and can’t get SGP or PHD to try and start a second copy.

Just a note - this is with the SGP 2.4 beta. Is that what you are using?

Starts second copy of TSX with:

SGP 2.4 beta
New TS scope driver
Windows 8.1

Does NOT start a second copy with:

SGP 2.3
Old TS scope driver
Windows 7

So I cannot say for sure which of those is causing the difference in behavior but I would guess that the different SGP version would be the cause. Maybe the SGP guys can chime in on this, maybe the logs will tell them.

This is probably because one this is running as Admin and everything else isn’t. Or vice versa. Everything needs to run at the same level for ASCOM to detect multiple connections. We typically recommend to run everything at a normal level.


Thanks Jared. I will check that. It could be that TheSky is running as Admin.

UPDATE: Yes, TheSky was running as Admin and SGP was not. That fixed it.


Now I just need to figure out why the API/PhD are crashing (see other thread). I think that problem is one that will require actual program changes as it is a true show stopper.

Running latest versions of SGP and PHD2, latest TS scope driver and windows 8.1 Pro x64

All works fine, with reference to Jared’s post I run nothing as Admin, all at normal level.

Oh boy - you are on dangerous territory there…! :wink:

No problem, turned out to be user error and easily fixed.

The real issue with the beta for me is the one on the other thread which makes the beta totally broken for my cameras - probably due to the SBIG guider API.