Pulsar Dome Driver for 64 Bit SGP?

I have just installed the 64 bit Beta and all kit connects, except for my Pulsar Dome. I’ve checked in the ASCOM diagnostics app and it says that the Pulsar ASCOM driver is 64 bit capable, but only registered as a 32 bit driver. Anyone know if there is a 64 bit version available please?

Hi Gav,
Oh you’ve just reminded me of the trials I went through to get this to work :-). I contacted Pulsar and they put me onto their software developer who set up a remote session with me on my observatory computer. Anyway, he tried all sorts of things and sent me new drivers to install, etc., and we went through a series of tests where it would work with 32 bit but not 64 and then would work with 64 but not 32 bit. The upshot was that he eventually got it to work, but I got the distinct impression that he was a bit surprised when it actually did. I don’t have the installer file on this computer, but I could dig it out and send it to you if you want to try it. You could check with Pulsar but they might just pass you on to their developer like they did with me. I thought it was maybe an issue with the way my PC was set up, but that fact that you’ve had the same issue does suggest the problem lies with the driver installation.

I just started doubting myself after I wrote the last post, so I connected to the observatory computer, installed the latest 64 bit beta (I have still been using the latest full release 32-bit version for my astro work) and it did connect up to the dome and I could make it rotate. I’ve not tried the 64-bit versions in anger yet as I had a problem with the sequence hanging on an earlier beta version, though the latest version appears to have solved that (for me at least).

Thanks for that Terry. Yes, I know the Pulsar software developer all too well! He has remote tinkered with the settings on my obsy PC on multiple occasions over the years. Lovely chap and always gets it working in the end. It sounds as though another visit will be needed to sort out compatibility with SGP 64. I think I will leave it until absolutely unavoidable though - the latest beta of SGP 32 is working fine on my system and I have seen other problems reported with GNS and SGP 64.
Thanks, Gavin.