QHY 600 - Cannot connect to SGP

I purchased a QHY 600M with a QHYCFW3. I installed the software and cannot connect either the camera or filterwheel from SGP.
My setup is as follows
A Pegasus hub v2 whereby I initially connect the USB3 and power supply through the hub, but an error message appear saying there was not enough power. So connected directly to a electrical socket.

The Pegasus is connected directly to a USB 3.0 socket from the Computer.
When I connect directly, the FW and camera green, red lights switch on.
The filterwheel does the initiation movements when connecting.
I have downloaded the most recent QHY camera and filterwheel driver package.

I am running on SGP latest beta version primarly used 32 bit up to this point.

The FW I tried connecting using the 4 pin connection from the camera, as well as independently with USB, nothing works.
When testing the connection in SGP I only had the camera and FW, no other equipment.

EZCAP 64bits , a program that is downloaded with the QHY drivers, and was able to control the camera succesfully with this program.
So, after checking the connections (USB 3) I had new cables , installing and reinstalling QHY software ( I have the latest All-in-One software.
I also tried EZCAP 64-32bits to see it they connected, all good through this software, I tried NINA and connected without a problem.

I read somewhere that SGPro uses ASCOM to control the Camera and FW, and maybe EZCAP connects with something else. But its weird with NINA and not with SGP.

Finally, I run of of option and deleted SGP 32bits and installed the 64bit version, but had no joy.
I saw that when I removed the QHY softwares, under SGP camera and FW the option to select a QHY camera was still available. I thought that once a software is deleted it should not appear in SGP.
Could SGP kept older version in this case of QHY software,even after reinstalling a new version.

I can provide log tomorrow.
Thanks in advance.

This is true, you’ll need the ASCOM drivers installed to connect your camera in SGPro.

Hi, just to let you know i have solved it. Sorry to bother just got tire of trying and trying.
All good.