QHY all-in-one pack gotcha with SGP 64-bit

Hi folks - I have had several issues with QHY cameras and connections recently and after a lot of installing/uninstalling drivers/registry cleans, I got the 32-bit SGP to connect over USB3.

I could not get SGP64 to, however. I then guessed (correctly) that the all-in-on QHY driver installer does not know SGP64 and does not put the necessary SDK files into the SGP program folder.
You need to manually navigate to the QHY SDK folder and add the contents of the x64 folder to the SGP64 program folder.
It now works. I have requested QHY to add SGP64 to its installer pack, so you there should be no need to do this in the future.

Thanks for the heads up on this, buzz. I was contemplating trying out SGP64, but now I think I’ll wait.

You shouldn’t need to do this. The right approach is not for QHY to copy that into the SGP directory but for the QHY ASCOM driver to be smart enough to know if the calling application is 32 or 64bit and load the proper DLL. This is how the ZWO ASCOM driver works.

What is happening now is that when the QHY ASCOM driver launches it looks for the dll to load and the first path it checks is the running EXE Path (SGP in this case) then it would normally go to the ASCOM folder where it should be checking. Copying that DLL into the SGP Dir effectively makes this work as the QHY ASCOM Driver finds the correct DLL. But ideally it should be smart enough without having to do this.


QHY drivers were once like that but they have changed their approach and with their latest all-in-one pack, they copy their DLLs to the various application folders during the installation. You are asked when you install which apps you have (EZcap, NINA, SharpCap etc) and it checks that the default folders are there for those apps, or prompts you for them.
I think they have taken a wrong turn here and they tried to help with a single update file but the result is chaotic.

That’s odd…that basically means if you install a new imaging app that you need to reinstall drivers or manually copy them over. Also means that you could end up in a state where the ASCOM executable is incompatible with the DLLs that are placed into the Application Folder…very odd.


Right now I would just like the drivers to work reliably for all my cameras. Some do not work through the paramount and others over usb3.

Then I’ll suggest where to put it!:sunglasses:

Jared is correct. Not following his recommendation could lead to possible DLL conflicts or version mismatches in the future. Surely the QHY folks should know this.

I am trying to get my new QHY 268M to work with SGP 64bit and am not having any luck.

  1. I first loaded the latest QHY all in one drivers (2021-02-20). After this, SGP v643 sees the camera and can at least shoot dark frames (i have not tested light frames yet). SGP v657 sees the ASCOM driver but the sequence does not start (log file reports infinite error loop regarding ASCOM camera offset, I have posted the log file in a separate thread).

  2. @buzz I have followed your advice and ran the QHY ASCOM 6.5 installer. No change for SGP v643, it still works. Now SGP v657 cannot even load the QHY camera ASCOM preferences and I get the error message in the screenshot below.

  3. I followed the advice in this thread and copied the 64bit qhyccd.dll file in the SGP v657 directory but no dice. Same error as in number 2.

Chris, what did yo do exactly to get the camera to show up in 64bit mode? I have tested the camera in NINA 64bit and everything works without any issues with the native driver.



couple of things to try - forget about SGP for the moment, can you connect to the camera in ASCOM diagnostics, using the 64 bit (or 64-bit NINA, using the ASCOM connection, for that matter)
secondly - take a look at your windows device manager, astroimaging equipment and QHY drivers. They should both have the device driver version 21.2.22

I have my system on right now - if you PM me with an email address, I could screen share on zoom if that helps.

Chris, thank you very much! I may have missed the window but I’ll send you a PM anyway.

You were right, the error message above was common to all imaging applications. I shouldn’t have installed the ASCOM driver again, it was already in place and something got messed up.

So I started from scratch. I uninstalled the QHY All in One driver and associated camera and ASCOM drivers. Re-installed everything. I ran the following experiments:

  1. SharpCap 64bit with QHY ASCOM driver: It works, images are generated and sent to the screen.
  2. NINA 64bit: I ran a short sequence of darks connecting the camera with QHY ASCOM driver and it worked. Frames were generated, downloaded and saved.
  3. SGP 64bit v657: The camera connects successfully, the cooler works. I launch the sequence with dark frames and the GUI says “Running Sequence” but nothing happens. The frames are not generated or downloaded. Sequence does not abort gracefully and I have to quit the application to have control of the camera again.

I haven’t tried SGP v643 again but I expect it to work.



Luca - take a look at windows device manager and the astroimaging equipment tab - look at the driver versions for the QHY USB drivers, what are they? Mine are 21:2:22 for both my cameras.
At first, one was good and the other was older. I uninstalled the old one and rebooted, and it automatically made both the later one.


Thanks again for the chat and the troubleshooting tips. Unfortunately, nothing worked.

  1. I uninstalled ASCOM 6.5, SGP 64bit, every QHY camera driver and application.
  2. I ran registry cleaner
  3. I reinstalled ASCOM 6.5 SP1 downloaded from thee ASCOM website.
  4. I reinstalled SGP v657 64bit
  5. I reinstalled QHY all in one 2021-2-20
  6. I reinstalled the updated camera driver 2021-2-25

SGP v657 is able to load the camera driver, I can take dark frames successfully in Frame&Focus but the moment I launch a sequence of dark frames, the sequence hangs and the log file shows the infinite loop of error messages related to camera offset.

I tried both a USB 2 and USB3 cable and it doesn’t change the outcome. Finally, the sequence does not abort gracefully and I have to quit SGP to stop the sequence.


Sorry for that. If any other ideas come to mind I’ll drop you a note.

Interesting - I just tried to use my QHY 178 guide cam as an imaging cam in SGP64 - it comes up with an error when it tries to retrieve ascom properties - same with any other 64-bit app. PHD2 (32 bit) connects fine. Have not been able to resolve it and reverted back to SGP32

I have found the problem with the QHY64-bit ASCOM driver for 64-bit SGP.
There are two versions of the QHY driver in their all-in-one pack. One for ASCOM 6.5 and one for ASCOM 6.4.
The 6.5 version only works with 32-bit apps at present (Version, whereas the 6.4 compatible version (…12) works with 32 and 64 bit apps.

I am still running ASCOM 6.5SP1. If I get unavoidable problems with the gain and offset controls, I will have to revert back to 32-bit SGP.

Hi folks - update - QHY sent me a revised ASCOM driver that works with 64bit apps. I should now be able to change the evet gains and offsets. Checked on two computers and with QHY178 / 247C and 183M cameras.

That’s great! Will they distribute it broadly?


Hope so. I confirmed it worked on the QHY forum last night. I don’t think it was camera model specific as the error came up with the ASCOM chooser but I tested it with 247c, 184 and 178 cameras to be certain.

It worked for me too! I downloaded it from the QHY forum thread:


I am now running SGP 64bit v661 with the QHY 268M successfully. There is another crashing issue I am sorting through but I believe it is completely unrelated.