QHY Camera options not showing up

Hi, I’m installing SGP x64 on a new laptop. It’s the first time I’ve done a fresh install in many years and the first time I’ve run it in 64 bit and I’m running into an issue with my QHY camera. Basically, the QHY camera option (QHY Camera-Capture I believe) does not show up in the Control Panel Camera drop down list, so I cannot use my QHY with my old profiles right now.

I’ve done a new install of the QHY all-in-one driver pack and the drivers seem to be working and are updated properly. The camera works in both SharpCap and EZCAP-QT x64. Is there an easy step I’m missing for SGP to be able to identify the QHY drivers? Does it use the ASCOM driver or one of the other ones? I know last year the QHY drivers had an issue with the 64 bit version but I believe that was quickly rectified.

Should I try downloading the 32 bit version of SGP to see if it works in that? Thanks.

Yeah, I have the same problem. I take it SGP is all pro ZWO now? :stuck_out_tongue:

Come one, fix this. I guess I have to use NINA for now

It works ok for me using latest 64bit SGP (version 4). And that includes ability to set offset by target which has been great. What version of SGP are you using?

During the QHY All-In-One install, I seem to recall there was a separate checkbox to select the ASCOM drivers. The ASCOM QHY driver install is required, to work with SGP.

I do seem to recall having some troubles with this in the past and having to install the QHY drivers more than once, before things worked properly. I think this was more an issue with QHY drivers than SGP itself.

If this was a general SGP issue I would expect there to be more comments on here?

Hope this helps.


I am using the 64 bit version with no problem at all ( same as Dave ) , I presume the ascom drivers are
not being installed for some reason.
As dave said you do have to select this option when installing the drivers from qhy

1 Like

Right! I reinstalled the driver, and I see the problem now. As mentioned, you have to manually select the ASCOM option. That is just stupid. Adding to the confusion, everything was working just fine in NINA and Sharpcap!

Oh well, it works now! Thanks guys :smiley:

1 Like

Glad you got it sorted. I think NINA and Sharpcap were using their own drivers and not ASCOM drivers? For the most part, SGP does not create/update their own drivers anymore (too many cameras to keep up with!).


Just getting back from vacation and seeing the replies here. Yes, it wasn’t an SGP issue but an issue with the deployment of the ASCOM driver on QHY’s all-in-one deployment pack. Apparently you have to manually check that one (which you’d think would be automatic in an all-in-one package) and I missed it the first couple of times. Everything works great once that actually gets installed.

You can run the ASCOM diagnostics and see if your camera shows up. If the ASCOM drivers have been installed correctly, you will be able to see your camera and run the diagnostics against it. Choose if you want to test camera in 32bit mode or in 64bit mode. If your camera does not show up in the ASCOM diagnostics, then there is no chance of the camera being accessed by any ASCOM program.


1 Like