QHY9 and Cooling


I am new in the forum… I have a problem with the cooling of my camera QHY9 using SGP.

I have set that when I connect the camera to SGP, the cooling starts ( -15 degress in 5 mins ). It was used to work very well before SGP’s update ( V ); now I have a problem: the camera doesn’t cool down when I connect it to SGP.
Even if I set -15°C in 5 mins, the power is not enough to cool the camera, infact the power remains set to 2% or max 10%.

I tried to cool down the camera with Ezcap, which is its software and it works normally. I tried to do the same thing with Maxim Dl and it works fine.

I re-installed SGP software and re-installed camera’s driver / Ascom camera driver but I did not fix the problem.

Can someone help me, please?

Thank you!



I have a new update… with SGP version v2.6.0.17 the cooling works fine.
I don’t know why it does not work in the last version.

Thank you


I have one QHY10 with the same problem, but with EZCAP the TEC working fine.

The version . have one update of DLL for the QHY, maybe is when start the problems?



Hello Leandro,

we have the same problem. With Ezcap the TEC works fine.

I tried to use the v2.6. 21 but it is seems that it doesn’t keep very well the temperature; I mean, if I want to set to -15°C, it arrives to -14.4°.; while instead using the version, if I set -15°C, it goes to -15°C(or really near ). I know that the temperature may can vary a little bit but the version is seems to be more stable ( about the temperature ).

Best regards



Maybe the user have QHY is better use the vesion .20 or .17 until arrive the solution in the new version for this problem.


@RAPALA @francesco.bat

Would either of you be able to reproduce the issue and include SGPro logs. This issue seems isolated to QHY cameras and it could be related to the new DLLs distributed.

I have a QHY8L and I have the exact same symptoms. In version .23 I have this problem and in version .17 I did not have the problem. Next clear night I’ll try to to get some SGPro logs and dropbox them.

As do I … see “Ver broke QHY10 TEC Control”

Alright… since there a decent number of folks on this thread, can I ask somebody here (who is a little computer savvy) to try two things (and test QHY cooling for each)? Should be easily testable indoors.

  • Go to the SGPro install directory and rename “QHYCAM.DLL” and “QHYUSB.DLL” to something else (add “_old” or something). Then copy these two (old QHY DLLs) into the same directory, restart SGPro and test cooling.
  • Either way, I would be curious how QHY cameras react when ALL QHY DLLs are removed from the SGPro directory. Please rename or delete any trace of both “QHYCAM.DLL” and “QHYUSB.DLL”. Restart SGPro and try again.

These tests are operating under the assumption that SGPro cooling seems broken for just QHY cameras. If somebody without a QHY camera is seeing cooling issues, please let me know. While there is no difference in the cooling logic between 17 and 23, 23 does upgrade the QHY DLLs and reinstalling 17 effectively downgrades them.

I tried two experiments as you suggested. The link to the old dlls doesnt work so saved the ver17 dlls and then substituted them in the v23 directory. No luck. A cool down to -10c in 5min didn’t work. TEC only reached 8%; temperature at 13.8C.

Removing the dlls completely also didn’t work. Same result.

Just to verify that the camera is still working properly, I reloaded SGPv17 and tried a cool down to -10 in 5min. After just a minute or so the TEC reached 12%. At 4 minutes it was at 32% and the temperature was -3.1. At 5min the TEC was at 38% and the temperture was at -7.7C. Though still not at the specified target, in one more minute the TEC reached 41% and the temperature was -10.5C.

So, as I have observed, v17 works, v21 and 23 do not.

1 Like

Excellent. Thank you for doing that. Maybe I’m barking up the wrong tree here.


Can you provide the logs from those runs when you get a moment. If it’s not the DLLs, I hope the answer is in there… that said, code issues would seemingly affect all ASCOM cameras and not just QHY. Either way, it seems worth a look.

Here are four logs, three with v23 and one with v17. I did a quick look; there’s not much in there with respect to TEC.
Unfortunately, I didn’t note which run produced which log, although if I had to guess I believe the last three were 1) v23 with the v17 dlls 2) v23 with no dlls 3) v17
sg_logfile_20170528220533.txt (20.1 KB)
sg_logfile_20170528221045.txt (22.5 KB)
sg_logfile_20170528221741.txt (23.0 KB)
sg_logfile_20170528222541.txt (23.0 KB)

Right. To me, it’s of more interest what is not in there. Specifically any error messages that might have been emitted during the cooldown process. The ones in your logs seem to have completed without error. This means (in theory) that SGPro, successfully completed the cooldown process and did not have any reason to believe it did not go well. The cooldown process lags behind temp so it does not attempt to confirm, by reading TEC temp, that the process was successful.

At this point it would be helpful to see the QHY logs in order to understand what the driver is doing when it receives a request to modify temperature.

Does anyone know where to setup logging for an ASCOM QHY camera? I took a look and can’t find where to turn on QHY logging. I can bring my camera indoors tomorrow and run tests …

My QHY8L is also having the same problem with cooling on v23. Just for grins I uninstalled and went back to v17. All is well with power averaging 45% to cool down 20c in 3 minutes. I installed v18, v19, v20, v21 with the same results. However when installing v22 the problem surfaced with power at 6-7% and errant temp readings before turning on the tec. Cooling didn’t work well. So far I haven’t been able to locate any camera logs.

I also have the same problem with my QHY22 when using v23. In my case, I’m using the QHY22-StarSenseSci driver. As such, there is no ASCOM log for the problem (at least that I can find). All is OK when I fell back to V21. I can’t be of much more help as all the log files are gone.

Frank Z…


According to ASCOM experts, you should be able to find camera logs in your local equivalent of:

C:\Users\UserName\Documents\ASCOM\Logs Date\

Every other known ASCOM cooler works with so I am unsure of why we seem to have broken compatibility with QHY. Camera logs will be a huge help in troubleshooting this.


I found the ASCOM logs for all my sessions. but the only devices in it are for the gemini mount and QHY filter wheel. I also found some logs when I was testing out my QHY168C using v17 which had no problems. After I upgraded to v23, I only used the QHY22 and there are no logs to be seen for this camera/driver in ASCOM going back months. Since the weather does not seem to be behaving for a week or so, I could pull my QHY168C from my other scope, install v23 and test it. Then if I see the same problem, I should have some ASCOM logs to send your way.

Frank Z…

I have looked on my computer where all my equipment hooks up to and I see no logs for QHY ASCOM. I do see some logs in the:

C:\Users\UserName\Documents\ASCOM\Logs Date\

It appears the only logs I have in this folder is when I run ASCOM Diagnostics. Maybe there is a “secret” way to turn on QHY ASCOM logging that we don’t know about. I do not see any switch in the QHY ASCOM driver interface to turn on logging.

After trying different versions of SGP last night and after reading Kens reply I wondered about the driver I was using for the QHY8L, which was the latest ascom driver. I was working on some compatability issues last night and I had installed the new Star Sense Guide driver v1.51.2 for my QHY5L-II guider so it would co-exist better with my QHY8L. The folks at QHY have recently brought out the guide and capture versions of the universal driver, as they call it. Had everything working well on my desk here along with my Mbox and SQM on v21. I just now installed the Star Sense Capture driver v1.51.5 for the QHY8L and its working well in v21, v22, and v23. It seems the cooling power and temp displays are sampled maybe every 15-20 seconds and I’ve seen 100% applied to the tec during the same 3 min 25c cool down which I used last night. The readings seem to jump around a bit. I might add that last night there was an ascom log for the QHY5L but none for the QHY8L but tonight both are in the ascom directory. The driver also allows for 2 capture cameras.and has an improved ascom properties selection. Give it a try.