QHY9 and Cooling

So it does seem like this is the issue. I’ll contact QHY to see if they can address this behavior. Even with a cool down of 0 it still takes FOREVER for the temp to actually cool. SGP does not control the power. We only set the temperature. So setting a temp of -20 on my QHY11 I would expect it to eventually hit that temperature no matter how often I check that temperature. Apparently though, the QHY driver will only increase the power when we poll for the temperature. So if we never ask for the temperature the driver will never increase the TEC power to make the camera cooler. And likewise I guess it will only increase it a certain amount per poll.

We’ll decrease the poll period and I’ll also contact QHY about addressing this in a manner that doesn’t rely on the client asking for the temperature to make the TEC functional.


HI Ken,

Dr Qiu said that he may be able to get a new version of the ASCOM driver out for the QHY22 and maybe the other older cameras that is incorporated into the new capture/guiding ASCOM drivers. This way all the cameras will behave the same as my 168C, which has no problem with v23. Also we will get ASCOM logging. Keep your fingers crossed…he said maybe this weekend.

Frank Z…

Any word on the release of new drivers?

1 Like

are there any updates about the new drivers?


At the risk of stating the obvious, this is also a significant issue for the QHY10 and its ASCOM driver.



Does anyone know if there is a stable solution to the qhy8l and cooling problems described in this thread?

best regards

I’m not sure about the drivers. But we addressed this a while back in SGP and it should be working in pretty much any version after If you find otherwise please let us know.


Hello John,

I had the problem with my QHY9 for the cooling -

I installed the version that Jared said and now it works perfectly. So if you install that version it should work normally.


Me too☹️ With the same problem

No problems with qhy8l and cooling. I am using SGP version

best regards John

What version are you using?


The latest one whatever that is 2.64

If someone will post some logs I can take a look. I can’t duplicate this with my qhy11.


I will Once I get home on Friday Where can I find the logs
Many thanks

You can find info here:


I am getting the same issue here too. What’s the solution chaps. Camera cools fine with maxium dl

I can’t help without logs. I’ll need the ASCOM log from the camera and the
corresponding SGP log.

Jared Wellman
– Co-Founder and Developer

Cool I think it might of been solved with the v3 beta version. Seems to be cooling much quicker. I’ll try later on tonight again.

Where can I get the file …

Seems like problem still there even with the beta v3

**It works ok now with QHY10 and the latest version of SGpro :+1::+1: