QHY9 Randomly Disconnects During Imaging Session

Hello Jared/Ken/All.

Hope all is well….

I do have to say this forum is a great resource, and I’m very impresses with all the knowledge being shared, and help given!

My issue is as follows…

I was imaging this past weekend and got a strange error from SGP several times over the 2-day imaging session. At some point during the imaging sessions, either in the middle of taking an image, or when downloading an image, a dialogue box popped up asking if I want to turn off the camera cooling. Regardless of choosing yes or no SGP had already disconnected the camera (as seen from the Sequencer dialogue box; camera connection button not lit/orange). Also, although the filter wheel and focuser (Robo-focuser) appeared to be connected (lit connection buttons), they we not responsive either.

I tried to reconnect the camera by pressing the camera connect button, but SGP indicated no camera was connected. I had to close/reopen SGP, and unplug/reconnect the camera USB cable in order to reconnect to SGP. All worked as it should…for a while. I got the same error several times over both sessions (about 5 or 6 times); Image count was anywhere between 2 to 12 before the issue happened.

I’ve read some posts here in the forum about the issue possibly being related to the USB hub, lack of a powered USB hub, and/or cables. I bought a new powered USB hub, and new cables, but these did not improve the situation.

My hardware remains the same: Losmandy G11, QHY9M/QHY Filter Wheel, QHY5L-II guider, Windows 7, ASCOM 6.2, and same QHY drivers I’ve been running for the past year. Prior to this session I upgraded SGP from to, and to the latest PHD2 -2.6.3 (from2.6.1). I’ve not had this issue previously with the older versions of SGP & PHD2.

I’ve attached one of the log files. Seeing I shut down SGP to clear the situation the error occurred around :11:25pm.

Any insight/help is always greatly appreciated.



sg_logfile_20170225222755.txt (140.7 KB)

Hi @Joe_Ram130

It’s hard to tell for sure without the camera’s ASCOM logs. Here is one side of the story (the SGPro side obviously):

  • Camera presented a general connectivity error with temperature (not related to the disconnect, but telling for sure).

[02/25/17 23:10:20.734][DEBUG] [CP Update Thread] ASCOM Camera: Error in GetCoolerTemp. : Object synchronization method was called from an unsynchronized block of code.

  • Fifteen seconds later SGPro detects an internal state mismatch. Specifically, SGPro is still under the impression that the camera is connected, but the camera’s ASCOM driver (Camera.Link) is reporting that it’s not.

[02/25/17 23:10:35.672][DEBUG] [Equipment Connectivity Thread] SGPro thinks the camera is connected, but it’s not, syncing UI…

This problem can present itslef for several reasons:

  • Failing USB cable
  • Failing / loose USB plugs in the camera, hub or computer
  • Effects of temperature on plugs and cables. Cold temperatures affect hubs especially badly.


Thanks so much for the quick reply, and the guidance. Given the WX this past W/E in Austin was not very cold, as well as having new cables and hub too, I’ll look to the camera USB connector for now. I’ll see if I can get the error by wiggling the cable during operation…

Also, I’ve attached the ASCOM file. It was 2.4 meg, so I had to delete parts: basically I took a chunk of data out from the middle section seeing the error was at the end anyway. Let me know if this is fine, or if I should email it to you.

Thanks Again


.ASCOM.DriverAccess.2228.180450_MOD.txt (768.6 KB)

P.S. How’s that APM 130 doing?


When this happens, check the lights on the DC201. They are known to be fairly fragile. If all of the lights are not lit, you may need a new one.



Thanks for the reply.

Now that you mentioned the DC201 I recall two things during the session.

First, the lights on the power supply seemed dimmer than usual, not sure if this means anything, but I dismissed it as probably nothing.

Second, I noticed the cool down temp was sporadic at times. As the camera cooled down the temperature increased (got warmer) by 5-7 degrees then continued getting cooler. During this time the cooling power was at 100% to cool the camera. I dont recall this amount of power ever needed to cool the camera before. Also. one time it overshot the target setting of -20C by several degrees (-23C to -24C), which has never happened to before. In the end the camera reached the target temp and I was able to image for a bit.

The cooling, then warming, then cooling again happened a couple times during the session. This happened when I had to disclonnect / reconnect the camera as noted above. I figured it might have been due to the abrupt stoppage of cooling,

Does any of this point to the power supply?

Thanks again.


One thing to bear in mind is that log files should compress really well because they are very repetitive.

The only exceptions reported are property not implemented exceptions for Gain and ElectronsPerADU. Both of these are acceptable because these are optional.

There’s a gap in the log from 23:09:41 to 23:10:20:

23:09:41.693 Connected Get Issuing Connected command
23:10:20.660 Connected Get GET Connected - COM
23:10:20.661 Connected Get True

That looks as if there is a connected command sent that didn’t get a reply.

The DriverAccess log is good if there’s nothing else, a good driver log may be better but not all drivers implement this.

BTW someone reported on the ASCOM group that their QHY10 camera driver does not pass the ASCOM Conform tests. I’ve no detail but it may be worth checking.

Definitely - either that or the DIN cable. One thing I have learned with the QHY cameras that use the 9-pin cable and the DC201 is to keep a spare off each on hand.



Thanks for the help. I’m searching the QHY forum to see if anything turns up that might help. I think it’s the power supply, so I should know soon. I’ll post accordingly.


Thanks. I’m going to get a new DC201 shortly. I did replace the 9 pin cable previously, so I don’t think it’s that, but for the money I’ll get another as a spare. I don’t think I’ll get the new equipment in time for this weekend, but should be able to post my results in a couple of weeks.


Thanks again for the tremendous help. It’s nice to know there’s help and a lot of knowledge only a post away!

More to follow…




Just wanted to post an update…

I updated SPG to the latest version, v2.6.0.17, as well as updated the ASCOM platform to
6.3 (from 6.2). Using the original USB and 9-pin cables, DC201, and the non-powered
USB hub, I ran the setup for about 3.5 hours today taking 10 minute subs with no issues.
I didn’t totally simulate the previous conditions when the errors occurred as I tested the camera on desk (rain, rain, go away…), so I wasn’t using Robo-Focuser, guiding, nor was the WX at 40F.

Not sure if the lack of extra traffic on the one USB port on my computer/USB hub has anything to do with it, but the results so far are good. Seeing my laptop has 3 USB ports would it be better to plug one device into each opposed to using a USB hub?

Anyway, I have another DC201 and 9-pin cable on the way, so if the problem occurs I’ll have something test.

Thanks Again!