Rigel Systems focuser suddenly having trouble

I’ve been using this for about a year with little trouble, but the last 2-3 sessions the focuser has refused to move in response to the initial move command in an AF run. I use backlash comp, and the backlash comp will run, but then the focuser refuses to move in to the position directed by SGP. So I go into the RigelSys/nStep software and manually set the focuser to the position SGP is commanding. Then the AF run picks up and runs as normal. Any idea what’s up? Version BTW, where should we upload our logfiles these days? Is there a space on the new forum, or should I just use Dropbox?


Just dropbox. Absolutely nothing has changed? No new software, drivers or
other? If the answer to that is no, I would start looking at USB issues.
Cables, hubs, etc.

I use a Rigel stepper controller and don’t have any problems. When it messes up, it’s usually a driver thing. I know this is a dumb question but have you tried rebooting?

Thanks Ken and Chris. The logfile is here:


You’ll see the issue in the first AF run. If the logfile doesn’t offer any clues, I guess I’ll reinstall the Rigel Sys drivers.


I am getting this also on occasion. I have found that I can cancel the autofocus and restart it and it may start back up. Other times, I have to disable and enable the driver for the focuser in Device Manager.

This is also with the Rigel Systems Focuser. Never looked at the log, but I’ll check it.


Yep… something is amiss here. Looks like some weirdness was introduced
in AF when backlash is on. I would recommend disabling this temporarily in
SGPro (or using compensation at the ASCOM driver level if it’s available).
We will take a look…

Thanks Ken and Adam. Last night my first AF run went off fine, but after an hour I had SGP do another run to touch up focus, and it happened again. Same resolution - I just moved the focuser in the 5 steps it was off, and then the AF run took off without a hitch. Several AF runs later in the night ran without trouble. I’ll post the log later tonight.

I’ll have to keep doing the manual nudging for now because I can’t run without backlash comp, and the Rigel Sys focusers don’t have backlash comp in ASCOM. I’m using the C11 stock focuser, and there’s way too much focuser backlash in it to achieve accurate focus without comp. Thanks for looking into this.


1 Like

Good to know, I was going to try to use my 12" SCT soon too!

There does not appear to be an issue with Rigel or AF, just backlash.

Ken, does that mean that the backlash comp doesn’t run all the way back in? The focuser just stops short of the requested position?

I don’t know. It looks like there is some odd request to move the focuser
with backlash on the first AF move and SGPro is somehow asking 9 times in
one second… then it appears all subsequent AF moves 2-N get backlash
compensation applied, but not un-applied (so your entire movement sequence
would be 500 steps outside if the intended range). This is complicated
because it runs in several threads and we might have some concurrency
timing issues…

Hi Kevin,

Sounds like similar issues as I am as shown in this thread I created:


Interesting, Peter. Yes, it does sound exactly like what you’re seeing. I’m running it as a I type, and I’ve seen it twice so far tonight. It looks like Ken is running it to ground, though.

Ken, if it helps, SGP just reported this:

[6/3/2014 12:15:50 AM] [DEBUG] [Camera Thread] Error in auto focus! Focuser failed to move to the auto focus position (84287). Focuser reports it is at 84101.

However, the nStep software is showing that the focuser is at 84291, not 84101. I’m not sure why SGP is seeing a different number than nStep.


You might want to ask Rigel Sys to add backlash compensation to their ASCOM driver. It does not sound complicated to implement. They probably could do it quicker than SGP fixing their backlash compensation because it sounds more complicated to fix in SGP.


Well, I’m hoping the fix won’t be that hard. It was working without trouble for a good year, so something probably just got changed in a recent release.

Still not sure what’s wrong. Haven’t had any time to look at it yet. We
should have some time to dedicate to this issue in the next couple weeks or

I believe I have a fix for this. I’m pretty confident that it will address the issue but I was having problems duplicating it reliably.

Also there is no guarantee that this is what’s causing the issue you’re seeing, although that’s highly likely as well.

Can you try doing a couple of AF runs with backlash compensation turned off? I know you won’t get good focus, but it would be nice to know that the culprit is indeed the backlash compensation.


Will do. I really appreciate you guys looking into this with all the other things on your plate. Rain tonight, but I should have clear skies Thursday or Friday night.


Hi Kevin,

I would still contact Rigel Sys. It might be more reliable for Rigel Sys ASCOM driver to handle backlash compensation than SGP’s backlash compensation. My focuser’s ASCOM driver has backlash compensation and it works well while SGP’s backlash compensation is disabled. I noticed Rigel Sys already has backlash compensation but that would only work if Temperature Compensation is enabled and I kind of find it odd. So if they already have backlash compensation code implemented, maybe it should be easy for them to implement outside of Temperature Compensation.

Hi Jared,

Will your fix help the issue I was having with Handy Stepper Motor from another thread? The test can easily be done indoors and it does not have to run AF. My problem was with SGP backlash compensation enabled (and focuser’s driver backlash compensation disabled) and using SGP’s Focus Control window to send commands to the motor always end up stop communicating with the motor and I have to disconnect/connect the focuser motor via SGP’s Sequencer window.

Hi Kevin again,

Maybe try the same test as I suggested. Use focus control window to control the motor with SGP’s backlash compensation enabled and disabled several times and monitor for motor positions. AF run may not be necessary. Set the backlash compensation as large as possible so you can physically see backlash in action.


I tested both with and without backlash comp last night. The log is here:

You’ll see the first couple AF runs were with backlash comp, and the second one failed. Then I turned off backlash comp, and several AF runs went off without trouble. I turned it back on when I started imaging, and the trouble started up again. So I nudged the focuser the way I have been the last few sessions. The AF run that started about 1:28am ran into the same problem (I was asleep at that point), so SGP did not capture the second target. While the log says that the backlash comp worked, the log ends without explanation after that line, so I’m sure it didn’t actually work.

So hopefully the fix Jared has lined up will do the trick. Thanks for looking into this.