I am using SBIG STF8300M, occasionally I get RX_TIMEOUT error when doing auto focus. I have never seen the same error when taking exposure (usually 15min) or “frame & focus”, as well as plate solve.
What is special about auto focus routine? and what are the possible reasons for this?

I use I downloaded latest SBIG driver and firmware.


After I dismissed the error message, auto focus continued, however I am not sure if SGPro took another exposure, or the failing exposure got downloaded again (or somehow successfully), but clearly HFR of this point was much higher than it was supposed to.

Have a look at this thread:

I still have similar issues - although infrequently at this point - I am now using an AutoHotKey script to detect the Error message and automatically press the OK button - 100% of the time SGP and my STF-8300M have continued on. AutoHotKey is a free open source scripting capability - the script is super simple and included below, it waits for the window named “SBIG Error” it then clicks OK, the script is in a loop so that it will handle any number of multiple occurrences - I wish SBIG would fix their wonky driver !!!

WinWait, SBIG Error
ControlClick, OK, SBIG Error

Thanks! I will have to check if I can get the older version.

Which version of driver are you running with?

In the atove thread, looks like reverting back to the older version had fixed the issue.

I did revert back to 4.94 build 1 and it was way more reliable than the later ones I tried - I look at it this way - there is no such thing as an error free digital data link - eventually if you push a enough data through you’ll get an error just because of probability. The real issue is that I could never convince the SBIG guys that they needed a better, more robust error handling mechanism - I have only seen a couple of instances of an image that was actually corrupted due to the error, I think it really boils down to a timing thing, with the result being a timeout waiting for some bit that will never come…

For me so far it only occurs during auto focus, is it same in your case?

Yes I have the same feeling, CCD seems less robust than other devices.

it seems to happen more frequently when the camera is rapidly acquiring and downloading - I just got my home built ASCOM focuser working and have not noticed much difference - however my system doesn’t hang anymore either because of the AutoHotKey script. The one thing that guarantees it for me is doing a focus and frame with a short exposure and a small subframe size so that the image is acquired fast and downloaded fast - you could try this and i bet it happens - it may be that the autofocus routines do something similar to get a lot of data