Screen Freeze in SGP

Last night and two nights ago, SGP screen froze on my computer. SGP continued to run fine, but I could not move any of the SGP screens. Last night this occurred immediately after I tried to input a new target to the list. Other program screens were normal, that is, I could open PhD, my Web browser, etc. Further, when PS2 appeared during centering, I could move that screen. I checked CPU use, it was fine (nominal values around 30% or lower).

My system is remote, working through Team Viewer. Restarting Team Viewer did no effect the freeze, but restarting SGP resulted in normal SGP behavior (second log). Naturally I would like to isolate the source of the freeze
I am wondering if anyone else has experienced this behavior. Log files from last night attached.
Thanks, Ed
SGP Log (147.6 KB)

There is a good chance that you have a window which is behind SGP waiting for a response. Try doing alt-tab to cycle through windows to see if there is a dialog waiting for a response.

Good tip, I will try that. Don’t ask me what I didn’t think of it in the first place. But does it explain why I could freely move the PS2 screens but not the others?

The screen has frozen again. No screens in back that would interfer with SGP. I am at a loss.

Next time I will restart the computer before runnig any programs and see if I can replicate the freeze.

In both of these logs, the last SGP interaction was with PHD2. It appears to be terminating the connection. I don’t know if that enough of a clue to help you. The developers will have to look at these logs to tell you more.

This is almost certainly a hidden window issue. There are no errors in the first log and all the threads appeared to have been running without obstruction. In addition to this, the last thing you did was initiate an action that presented a new window. There is a known issue in the .NET platform that sometimes confuses window “z-order” (especially with complex windowing apps like SGPro… with all the floating modules and that kind of junk). That said… even simpler windows like ASCOM driver settings will often exhibit this “hidden window” issue. Lastly, the issue seems to be exacerbated by remote viewing applications.

So… certainly not the answer you want to hear, but this is a list of things you can try when it happens:

  • The new hidden window may still be active (have focus) even though it is not visible. Hitting ‘esc’ might close that window and return control.
  • Use ‘Alt+Tab’ to cycle away and then back to SGPro… sometimes this forces the screen to redraw and corrects the z-order.
  • Click the SGPro icon in the task bar (several times).
  • Hover over the task bar icon (Windows 8 and 10) to see a list of open windows. The one you want may be in the thumbnail list that appears.

Thanks, Ken. It does look like a hidden window issue. It also seems to appear when I try to modify the target list, but I don’t have enough data yet to say that with certainty. I will try your suggestions next time it happens. The alternative is to simply restart SGP (camera remains cooling, no end of sequence actions) and then restart it. I did that last night with no significant consequences to the sequence run.

I really like SGP. It’s taking some work to learn all the aspects of the program, and fortunately I have an experienced user who has been very helpful. As I learn more I am more impressed.


The Windows experts claim that the hidden window problem is a feature, not a bug. AIUI each process has it’s own window z order and it is designed so that one process can’t force its windows to be on top of another processes windows. There should be an entry in the tool bar for each window and that’s the official way to select the window you want, but earlier applications may not do this. I’ve tried all sorts of things to get things such as a driver setup dialog to be visible and the best I’ve found is to minimise, then maximise it.

Thanks, Chris. We can only do the best we can and I appreciate your efforts.

On a related note - sometimes I switch from a large display to using the laptop by itself - and apps like sgp will not show windows that are off screen. I wanted to run autofocus and I could not access the window at all. Fortunately I realized there was a Run button in the Focus control page - and when I clicked it the window appeared. But if there had been no such button - clicking on the little gear icon had no effect because the control was already displayed off screen - I think.

Is there any way to do the equivalent of ctrl-tab or something to access child windows that are either hidden behind something or off screen?

I have seen the issue of a frozen screen also and I had no idea what the problem was and had to restart. Then I figured out it was due to a hidden window - so I have been aware of the issue. But I thought I somehow got hold of the hidden window and resolved it. If it is on screen but hidden by things then you have a chance to get access - but if it is off screen what do you do?


I don’t think so. This would only work for non-modal windows.[quote=“Chris, post:9, topic:4920”]
There should be an entry in the tool bar for each window and that’s the official way to select the window you want, but earlier applications may not do this.

I’m actually trying to figure this out… All I can find is provision to add “multi-doc tabs” or “multi-doc windows” to the task bar. How to add a simple child dialog is not immediately apparent to me.

My observing partner may have found the problem: USB power saver may turn off the USB ports. In Win 7 this is under the USB Root Hub: “Allow the computer to turn off this devise to save power.” That has been turned off, we shall see with a few sessions if this was the problem. All power saving options are now off.

1 Like


Interesting… and very unhealthy for SGPro if that is happening. I’m curious to know how this turns out so that we can, if necessary, possibly query the system and provide a warning.

Well, in spite of turning off power saving and going through all suggestions by Ken about trying to move SPG to the front, I am still experiencing freezes. In fact, SGP appears to be at the front. The program itself does not freeze, it chugs along taking my images. But, I cannot do things like move the sequence window or pause the sequencing. I can open, work with and close other programs (PhD for example).
This may be idiosyncratic to my particular machine, especially if no one else has the problem.

Perhaps I will download the latest version and try that. My version is 2.6.05. CPU load while running is about 18-28%…

Added: Here is the work-around I found. Use the task bar to end the program. SPG will ask if you wish to run “end of sequence” Respond negatively. SPG will then ask if you wish to turn the camera cooler off. Say “no.” Then reopen SGP, load the sequence and proceed.

I tried one more thing and it seems to be working. I assigned SGP higher priority via the Task Master. Tonight no freezes, I will report back after a few sessions, but am hoping that this solves my problem. Nothing wrong with SGP, no problem with hidden screens if the solution is simply upping SGP to “Above Normal.”