Sequence aborts when attempting restart of guiding


After using Framing & Mozaic Wizard to create a sequence, and starting the run, SGP aborts after the blind plate solve and when attempting to restart PHD2 guiding.

Aprox time of issue: [03/21/20 20:22:11.160]

Link to Logs

Useful Info

Here are a few screen shots that show the situation:

SGP says “Resuming the auto guider”
01 - Hung resuming guider

PHD2 is guiding …
02 - Guiding is running

SGP aborts and says guider is not running, but it is …
03 - SGP says guider not running, but it is

OS: Microsoft Windows 10 Enterprise
.NET: 4.8

in PHD2, under Tools, is Enable Server Ticked ? and can SGPro start PHD2 if it wasn’t running (it should be able to) ?

Just a guess: Look at your settings and see if there’s a value for “settle at <” under the autoguider tab on equipment profile or control panel. It may be that PHD did not settle down enough, in time. But, I’m only guessing.

Hello Dr.

Yes, the server is enabled, and SGP actually starts PHD2 and connects the mount and guide camera.

Here are my settings …


Should I try longer than 1 second for settle (I believe that was the default)?

Try setting the Settle at to 0.5 pixels & time to 5 seconds

So… that still might not be the cause of your troubles… but note: Your setting wants 1 tenth of a pixel which is pretty damned tight guiding, while the portion of the graph you show in the picture you posted shows the RA guiding swinging by more than a third of a pixel, so that was out of bounds. And, that value is not bad, (to my way of thinking, though with your equipment it might be unacceptable, I couldn’t say), but that could just be the seeing at that time, rather than anything in particular wrong with the guiding or the mount. As the good Doctor Ju Ju suggests, moving to a higher setting, (tolerating more jitter), might solve the issue.

One of the Moderators or Developers could weigh in on whether or not the precise error message you got could have been a result of guiding not settling quickly enough.

Might try to loosen up your settling criteria. You are taking an image every 1.5 sec in PHD2, and 0.1 pixels is pretty tight.

Try a lax setting like 3 seconds and <3 pixels. See if that helps.

First, thank you for the tip … I will try changing those settings tonight and update this thread. I am using a ZWO ASI120MM-S on a 60mm Orion guide scope (240mm FL), so I am trying to find settings that work best with that equipment. I am going to try 0.5 pixels at 5 seconds.

Tonight I am going to try a very basic set of SGP tasks so the log file will be straight forward and not have a lot of “fiddling around” trying new settings.

And second, a really big thank you the image of your log reader. I went to the cetialpha5 site, and downloaded a copy. Great tool!


Last night I tried a simple test using the modified PHD2 settings. Here is the workflow:

  • Loaded my M42 sequence (built with Framing & Mosaic Wizard)
  • Connected all equipment (this launched PHD2 and connected everything)
  • Started sequence

Here is the SGP log file from that session …

And here is the PHD2 Log:

It appears that SGP made it through the blind solve and then tried to restart the guiding. But then it just sat there waiting for PHD2. After several minutes, I looked at PHD2 and saw that it was guiding merrily away (no lost stars). After several more minutes, SGP aborted the sequence.

To be honest, I am getting really frustrated. I have been working for weeks trying to get my first successful sequence to complete, but have never got all the way to the end before an error. I have done several settings tweaks which seem to help move it along, but this app seems to be way too touchy and requires many things to be perfect before it will run.

Help from the developers will be greatly appreciated … thanks,


Do you have the PHD2_GuideLog from this session? The debug logs are very dense and take a long time to go through.

From the SGP side it appears SGP timed out waiting for the guider to report it was done settling.


Here you go … thanks

The first part comes from the guiding called by SGP … and I can see where PHD2 settling failed. Any idea what may cause this?

After SGP aborted, I stopped guiding in PHD2 and then restarted a few times by hand. So those efforts show near the end of the log.

Closing due to inactivity. If this is still an issue, please send the requested information and “uncheck” this thread as solved.