Sequence will not start exposures (Beta651)

This occurs with the latest Beta 651 for 32/64 bits.
Run sequence - everything connects - slews to target, focuses, plate solves, centers and starts up the guider.
SGP reports it has settled… and then does nothing.

This is a new one on me. I’m using a new QHY camera, but it has already worked to allow the focus and platesolving to run?

Same problem as in this thread. Waiting for ASCOM and SGP to update the code …

cannot find that link - what changed? PHD2 / SGP or ASCOM? ( this is the first clear night in weeks)

Thread title - Build 651 Stuck on Running Sequence - Posted 12/20

sorry the link says it is either private or not found.

There is something going on with other equipment as I have been doing dark sequences all day without issue. Something in the handover from PHD2 back to SGP maybe?

It’s a specific issue with certain versions of ASCOM and the Client portion that SGP is linked against. Short story is we were waiting on ASCOM to address a bug in a newer release. They’ve addressed it on the client side but haven’t put out the new packages for applications to consume. I just checked on this earlier today and it looks like those packages still haven’t been updated but they’ve made it self service now so I should be able to address the Offset issue in a couple of days.


Thanks Jared - I tried going back a few versions of drivers, SGP but have not yet found a way around it. Is this something introduced with an SGP beta, ASCOM, or both?


I had the same problem on one of my imaging setups and reverting to SGP v643 addressed the problem for now. Same error message related to Offset in the ASCOM driver. Everything else stays current (ASCOM 6.5SP1, PHD2 dev3 version, latest version of camera ASCOM driver). The camera on this setup is a ZWO ASI294MM.


1 Like

Hi, I’m not sure what an ASCOM nuget is. I notice 657 has been released on Feb1 - does this overcome the issue in this thread?

It should yes. Though there are some reports of ASI cameras still having a similar issue…but I haven’t been able to reproduce it with the simulator or with the ASI 174mm that I have.


thanks - I’ll try it with the QHY as soon as I can.