Set ISO for DSLR via API

Hey all,

I am trying to troubleshoot an error in PEMPro 3 Beta. No matter what ISO I configure it in, SGPro returns this error when the Polar Align Wizard attempts to take a photo using my Canon 6D, which SGPro is able to use with no issues:


SGPro TakeImage Failed(1): SGPro: StartExposure failed: Invalid ISO option specified!


When I look in the SGPro logs, there are no entries for the interaction between the two programs. Is there a way to turn on more verbose logging?

Logging is generally pretty verbose. Having said that it’s also likely that the API was never tested with dslrs and might not be doing the right thing with iso. I’ll look into it this weekend.


Thanks Jared! :slight_smile:

In case this is useful, here is what the PEMPro Logs show:

0000044 2016-08-10 22:46:48.762: Debug, SgProCam, Sending: http://localhost:59590/json/reply/SgCaptureImage, Params: {“BinningMode”:1,“IsoMode”:1600,“ExposureLength”:15,“Gain”:“”,“Speed”:“Normal”,“FrameType”:“Light”,“Path”:“C:\Users\bill\Documents\CCDWare\PEMProV3\SGProImage”,“UseSubframe”:false,“X”:0,“Y”:0,“Width”:0,“Height”:0}
0000045 2016-08-10 22:46:48.763: Debug, SgProCam, Response: {“Success”:false,“Message”:“Invalid ISO option specified!”,“Receipt”:“00000000000000000000000000000000”}
0000046 2016-08-10 22:46:48.763: Error, SgCaptureImage, Invalid ISO option specified!

That is useful :slight_smile: makes it so I don’t have to go searching for their command! I’ll see what is happening on our end when that is sent in.


Awesome! Would be great to be able to use PEMPro with SGPro. I have a ASI1600MM-C on order, but I use my Canon quite a bit!

1 Like

I used it and it works with my STF8300. The only issue I ran into was if I didn’t use a small delay (1 sec) between pictures, PEMPRO would request pictures faster than SGP could take them and it would throw an error after awhile.

I was really happy when he added support for SGP to Pempro (and blanket ASCOM support as well).

Yeah, I plan to test it out with my ASI1600MM-C which arrives today. I am sure it will work great with that camera, and hopefully the issue with DSLRs can be figured out!

1 Like

Hi Jared.

Any update on this issue? I have a Canon 6D as well and I am getting the same error message.

I have tried checking and un-checking the “Use Camera ISO” option in the SGPro Config in PemPro but that doesn’t seem to make any difference. I am able to “Take One” from the frame and focus module in SGP so I know that camera is connected and able to take an image. Any help you can offer would be appreciated.

Andrew J

Just to follow up, I contacted Ray in the CCDWare forum about this issue as well. Here was his response:

“Another user reported the same problem a couple weeks ago. It might be a bug in the camera control interface or the way PEMPro is using it. I haven’t heard from the other user if there is a solution yet. If something needs to be fixed in PEMpro I will do it right away but I think the ball is in SGPro’s court at the moment. If you hear anything please let me know.”


Please let me know if you need any additional information from me in order to investigate this issue further.

Thanks for your support. I am eager to get this working so that I can try out the Polar alignment wizard in PemPro.

Andrew J

No real updated. But moved it into the 2.5.2 feature set for additional investigation as I’m pretty sure that this just isn’t currently implemented for DSLRs.


Thanks Jared. Let me know if you would like some help testing when you get to that point.

Andrew J