Settling every frame?

I am taking extremely short exposures (sometimes as short as 5 seconds) and I lose nearly half of my sky time to the settling feature.

If I set it to dither every 24 frames (once every two minutes of integration) it still chews up a lot of time settling between every frame.

I think the intent of the settling is to have it settle after a dither, but since I’m not dithering every frame I don’t need it to settle between every frame.

Instead, what’s happening, is it waits to settle after every frame. Even if it set the pixel setting extremely high and the wait time extremely low (1 second) it still chews up 2-5 seconds of every frame waiting for the guider to settle. I’d rather it didn’t settle every frame, but rather only when I dither.

I tried to turn the settling feature off, but what happens is it doesn’t ever settle, including after a dither, so I end up taking several useless frames (mount moving) during the settle time…

I don’t think this is working as intended. Is there a work-around? I’m getting close to skipping SGP when it comes to these short exposure times, it’s just too frustrating. SharpCap Pro’s new beta incorporates guiding better than it used to, but they have their own issues w/ settling making it less than useful when you have exposures above 10 seconds (it doesn’t pause capture, it just “skips” that frame during the settling…which ends up wasting THAT time).

I feel like there has to be a compromise here!

Hi Dennis, I’m not sure if it would be a complete solution, but have you tried setting the settle time to zero? PHD2 will report “Settle Done” on the completion of the next guide camera exposure assuming the guide star distance is within the tolerance. That should reduce the settle time to about 1/2 the guider exposure duration on average.

I did try that. Unfortunately, when it does dither, it doesn’t wait to settle after dithering and the next 1-2 frames are useless forcing me to find and remove them from the stack. That’s actually a bigger pain in the butt than the time wasted between frames with settling (since at least that wasted time can be spent inside out of the heat/cold).

I’m out of ideas on how if possible to fix this. Thinking maybe not possible w this version of SGP

No, you’re correct. SGP will minimally try to settle prior to every frame, even if a dither didn’t occur. We’d have to make a change to only settle after a dither.


Is there any reasoning behind this? What is the likelyhood of a change?

Did this get fixed? I’ve drifted away from SGP due to this issue and would love to come back.

Yes, this was addressed in the Beta a while back. SGP will now only settle when a dither has occurred.


Is this just fixed in V3?

I haven’t had an opportunity to test this again due to weather. When was it fixed I don’t see it in the patch notes.

It was addressed in the V3 beta. I can’t recall the exact version but it’s been a couple of months.


So I paid $99 in 2017 and was very happy with sgp But when only doing 30 second hyperstar subs imaging time eaten away by pointless settling when no dither performed. A few days ago another $79 dollars spent simply to try and claw back 30% of time my mount sits doing nothing.
This issue had been raised many times before v3 existed.

Okay, this is doing it again. It was DEFINITELY fixed as mentioned above but I was away from home and when I was home had bad weather until recently and haven’t got to do imaging in a while and some update since then broke this again, maybe? I can post logs if need be.

There has been a change in this area. I’m not saying there isn’t a bug, but what you may be experiencing is that SGPro will now force settling before every frame if the PHD2 guider error is above your settle threshold when the exposure starts. I can take a look at logs if you want to post them.

Log file is here:

I had it set to dither every 6 frames. Settle to <0.4 for 3 seconds after dither. It dithers every 6 but settles every frame no matter what (it was almost always below 0.4).

You can see an example of what it’s doing at 22:19:07.408 on the clock, line 13781 in the log (I just drilled down to a random example, it did it every time).

Ok, I’ll take a look through.

Thanks. I hope it’s an easy fix or user error but I could not for the life figure it out late last night.

This has been addressed and will be out in the next release. If you had ran auto focus prior to the sequence starting you could have gotten into this state.


Oh, weird! Thanks for looking into it.