SGP 2.3.9 fails to detect need for meridian flip

Pretty serious error last night. I was imaging Sh2-174, near Polaris, so started on the W side of the meridian pointing N. Fortunately I stayed up until tracking crossed the meridian because SGP failed to detect the need for a flip. Not sure what happened there - I was doing long exposures (30min) so tracking was 10-12min on the E side of the meridian and the Astro-Physics V2 driver window was displaying CW Up. However the frame finished and SGP just continued onto the next frame without flipping. Very worrisome behavior as I often just go to bed and assume all will be well. Only thing I can think of is that I believe the AP driver doesn’t allow access your usual command (?SideOfPier?) and so it has to use the slew command which then detects that a meridian flip is needed. Could that failsafe method have been disabled somehow?

EDIT: I should have mentioned that I immediately paused the frame and ran the meridian flip manually and it worked perfectly, so the problem was in SGP not triggering the flip, not a problem with the mechanics of doing the meridian flip.

Anyway I can’t trust SGP to flip until I figure out why it missed the trigger. I’d post my logfile, but I’m not sure how to do that now???

thanks, Keith

Any free service like Dropbox will do

Here (hopefully) is a link to the Dropbox logfile:


Keith… that link worked fine. Looks like you had some initial issue with mount sync. Even at 22:04 (the first check for pier flip), the check for side of pier shows that your AP mount reports the scope on the east side already. At no point, does your mount report the scope is on the west side until AFTER you perform a manual meridian flip.

[12/04/2014 10:04:37 PM] [DEBUG] [Sequence Thread] Checking if Meridian Flip is needed
[12/04/2014 10:04:37 PM] [DEBUG] [Sequence Thread] Meridian flip not needed, telescope on East side

Wow, that’s odd. Any idea how this would happen? Just a one-off quirk or something I should monitor for?

No idea really. Maybe someone with an AP mount will answer since the problem likely originated there.


I’m not sure if this is the problem but since the target was near the pole are you aware that when “under the pole”, the pier-side reported by the mount essentially reverses? This is not AP-mount specific. It is the way ASCOM defines pier-side.


Interesting. Jared and I will have to discuss this and see if we have changes to make.

You probably know this but the best place to reference info on this is the “SideofPier” property documentation in the ASCOM driver’s “ASCOM Platform Help” CHM file. It’s in the ITelescopeV3 Properties section.


I’ve read that more times than I care to in the last couple of days :-/ and yes, what you’re saying about pier side is correct and we’re not currently accounting for the case when it goes below the pole.

Looks like Cepheus was definitely below the pole when this failed. I’ll address this in the next release.


So I’m wondering, did this meridian flip issue get fixed?

This has not been addressed yet…but it should only affect you when you’re imaging under the pole.


We have not yet addressed this issue.