SGP beta filter list pull down empty

After I upgrade from to beta, I found the filter list pull down is empty, and I am not able to change filter manually.

Pull down list empty in Set filter position:

Filter list was defined:

Log: (3.0 KB)

The problem persists even I downgrade to

Please help.

I fixed it by starting from scratch, to select the camera and filter wheel in the sequence, and define the filter list again in the control panel.

It looks the entries might be lost during the upgrade to beta.

Arr… the problem is not completely solved.

I closed SGP, reopen again and the filter list setting got lost. The list is only shown under define filter list, but is empty in set filter position and in plate solve TAB.

This applies to both beta and also the downgrade to

I really need some help, as previously I got all these setting saved, and just go to the field, but it looks I have to set up filter list every time when I run SGP.

The beta may require an extensive testing.

Is it suggested to completely remove SGP, and reinstall, to minimize the risk caused by the beta upgrade?


One more finding:

  1. The issue happens when I use “Apply Profile to Sequence”. The Set filter position pull down list is empty.
  2. This does not happen to “New Sequence with Profile”. I find the list of filters in the pull down.

Log: (4.1 KB)

This should have nothing to do with the upgrade. Filters are a property of your sequence file. If you saved your filters to the sequence file, then reopen it to find them gone, we will need to see the sgf file you are using. Earlier you mentioned that you closed SGPro and they were gone. This will always happen unless you save the sgf file to disk and reopen it.

I have found exactly the same. It’s a real pain. The sequence will access the filter wheel and change filters but they are all missing on the dropdown menu.

I did find a bug here, but that does not really explain the rest of the issues you reported.

Please expand. This is not enough information for me to help you figure out what is going on.

There was an issue where applying a sequence to a an existing sequence could empty the filter list for the sequence (a bug in attempting to map filters from one profile to another). I did not find any issues with the saving or using of filter lists in general.

It looks the issue is gone with beta.