SGP Crash with Planning Tools

I uipgraded to the latest version of SGP this morning. I open a sequence that I had been working on before the upgrade and went into the target settings and clicked on the Planning Tools link. When the window came up it caused SGP to crash immediately asking if I want to quit or Continue. Continue would just cause SGP to raise the error again, so Quit was the only option. I uninstalled SQP and re-installed and tried to open the Planning Tools again, but received the same error message. Let me know if you need me to send you the log files. I am running Win10 version 1909.

Update: If I create a new sequence from scratch and attempt to use the Planning Tools, then I don’t get the critical error message. So the issue appears to be present when using Sequences created under 3.0.3.


Here is the text from the Error message:

*See the end of this message for details on invoking *
just-in-time (JIT) debugging instead of this dialog box.

*************** Exception Text ***************
System.NullReferenceException: Object reference not set to an instance of an object.

  • at SequenceGenerator.Astrometry.a(DateTime A_0, Double A_1, Double A_2, UserProfile A_3)*
  • at ot.qz(DateTime A_0)*
  • at A_0, MouseEventArgs A_1)*
  • at System.Windows.Forms.Control.OnMouseMove(MouseEventArgs e)*
  • at System.Windows.Forms.DataVisualization.Charting.Chart.OnChartMouseMove(MouseEventArgs e)*
  • at System.Windows.Forms.DataVisualization.Charting.Chart.OnMouseMove(MouseEventArgs e)*
  • at System.Windows.Forms.Control.WmMouseMove(Message& m)*
  • at System.Windows.Forms.Control.WndProc(Message& m)*
  • at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)*
  • at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)*
  • at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)*

Hi. I’ve had a similar problem. I’ve slighltly modified and saved my User Profile and I’ve created a new sequence with profile (the working one I already had). After that I entered into target setting and picked Planning Tools button. It worked right.


EDIT: I’ve added another target and it crashed again. For some reason my SGP sometimes sometimes forget it had a user profile assigned.

AFAIK, if a sequence does not have a user profile assigned, Planning Tools crashes everytime.

This issue is fixed in (it did not make the cut tonight… will be out in a day or so).

Very glad to help to solve a bug. It is nice you solved it so fast, thank you.