SGP - QHY10 images blank except Amp glow

Hi all. Last night I upgraded to Immediately, my QHY10 failed to deliver images, only providing blank shots, with a vertical line down the centre of the screen, which appears to be amp glow.

I rolled back to the previous version of SGP and problem solved. I reinstalled the new version and the same problem again. Has anyone else had this issue, and is there a solution please?



An imaging buddy using a QHY8 is seeing exactly the same thing with v3.2.0.457. Thinking there was a problem with the camera, he switched to his older SXV-H9, which is working correctly. When I helped him setup his SGP a few months ago, his QHY8 was working correctly but I don’t remember the version of SGP that was being used at that time.


I had the same issue yesterday as well with my QHY10. After I rolledback things seemed to work properly.

I’ve been using my QHY8l on v357 up to now. Grabbed an inside shot set up on my desk. Upgraded to 479 and with everything else the same experienced the same problem. Pics attached. I’d be happy to assist here since I’m on the bench.


@Ross what was the “previous version” that you reverted back to that worked?

@Bkoch would you mind testing and seeing if it has this issue:

We may need some help identifying where the issue was introduced…for whatever reason the QHY10/11 have always been a “little bit different” compared to how their other cameras handle things.

Thank you,
Jared works here. The problem surfaces between and Have anything in between I can plug in?

Good afternoon,

The version that worked was and is

Thanks for your help :slight_smile:


That’s very kind - yes, I have it working by rolling back to Nothing beyond that seems to work. :slight_smile:

What a great community this is… the cameras many not work, but at least we’ve got some great people.


No, there were no releases between those versions so that narrows it down nicely! I’ll see what could have caused that in .478.

I’ll probably have something for you to test though :wink:



Further to the below issue, I’ve just restarted my machine and tried to connect with my QHY10 to SGP and now I have exactly the same problem with that version… it’s so strange - never happened before. Do you have any thoughts please?


I have similar issues with my QHY8 Pro.Ii posted earlier that ver 478 does not work. I also tried 478 which was the same . Ver 457 works perfectly.


I’ve got s similar problem although in another program using QHY native driver. I told those developers about it and after contacting QHY they found the issue that affects the older CCD models (they switched away from using winusb in the SDK, which broke support for the older models) and it will be fixed in the next SDK release. EDIT: in that program, if I install the the dll from 2/28/2020, the camera functions again. Dont know if this is the same problem

Thanks for that, very helpful . What does SDK mean please?

Ah thank you :slight_smile: Brilliant. Ok, so you may have gathered that I am quite new to this… Where do I find the .dll from 2/28/2020 please?


I have not used SGP yet. But it looks like it uses ascom to control the QHY cams. The program I am using uses QHY native drivers, so I don’t know if this problem is the same or not. With the native driver, QHYdll was the problem, with the ASCOM driver I just dont know, but I mentioned it in case the developers of SGP need to look into it.

Thank you J You’re right – SGP uses the Ascom driver. I hope that they can fix it…



Hello. I just discovered my QHY12 is experiencing the same issue. (see attached images). If I use the EZCAP software that comes with the camera (and uses windows native drivers I assume) it works fine. However with SGPRO/ASCOM it seems broken. I see the temp. workaround is to roll back - how do I do that? Thanks!

Yes, that is the way that I have got it working at the moment… to roll back to the previous SGP version. Just go to their website, download the prior version, and install it. It will install over the top of the old version. Don’t uninstall your current version before you install the new one – I did that and I lost all of my settings etc… So just install the old version and you’ll need to re-register it on their website too probably.

Good luck.



I just moved up from v457 to v519 and all is well with my QHY8L. Nice work, guys!