SGP 3.2.0.660 Hangs up on "Downloading" Image

I recently purchased a new ZWO camera (ZWO ASI2600MM Pro). I am trying to image with it in SGP and SGP keeps hanging up on “Downloading.” It won’t work in Frame and Focus or in the Sequence. It downloads images which are less than 2 seconds in length but it takes much longer than it use to. Any help would be greatly appreciated. I have the latest version of ASCOM and have the driver for the camera installed. It has worked before.

Each time I’ve had this happen, the USB Traffic setting in the ASCOM driver had gotten reset to 80 (usually after an update to the driver). I set mine to 40 and the problem goes away.

Ok awesome. That makes sense. Can you tell me how to reset it? I remember doing it several years ago but haven’t updated ASCOM in a long time lol so I forgot.

On the Sequencer where you connect the camera, filter wheel, etc there is a wrench icon next to the camera connection. Click that and it will bring up the ASCOM configuration window for the camera. You can adjust the USB Traffic from there. (you might need to tell it to show Advanced settings or something along those lines when you get into the ASCOM window)

Great thanks!

So I checked it out and the USB traffic setting is low (40) as you recommend. I did some experimenting and found that if I have the camera cooler fan off, it won’t download the image (or the download is extremely slow) but if I have the cooler on, there’s no issue. I’m not certain why the cooler fan setting would impact the downloading of images but definitely something to look into.

I’d recommend the 64bit Beta of SGP for this camera. The ZWO 64bit drivers seem to be more robust and SGP also has more memory overhead in the 64bit version.

Jared

Had same issue with 2600MC. Had to swap out USB ports - went from USB 3 to USB 2 and it worked. Also power cycled laptop and it worked using the same USB 3 port. There are other solutions if this doesn’t;t work. I had a long thread in Cloudy Nights and got a lot of help with some deep Windows settings. But try swapping the ports first.

Interesting. Do you have 12V supply attached when the cooler is off?

I found that with my 6200 I would get hangs / failures downloading images if the the camera was only being powered via USB - for me, the 12V supply needs to be attached, regardless of whether cooling is enabled or not.

Zwo documented that it might be necessary to plug in the 12 V supply - depending on the power supply of the USB host: https://bbs.astronomy-imaging-camera.com/d/11142-asi2600-no-exposures-over-2-second . This is valid for the 6200, 2600 and 533 models.

Bernd

No I didn’t. I think that’s the problem! Thanks!

Awesome thanks for sharing!