SGP beta: issue with AF metric set to ASTAP HFD

I wanted to compare the AF metrics “SGP HFR” and “ASTAP HFD”. When I set AF metric to ASTAP HFD, the following issues occur:

  1. In spite of having set the AF exposure to 15 s, the AF frames are exposed only for 1 s. Since I applied a NB filter this cannot produce useful AF results.

  2. After download of an AF frame, the following error is shown:
    “ASTAP - Error running auto focus. Error starting ASTAP. Der Prozess muss vor dem Bestimmen der angeforderten Information beendet werden. HFD is 0!”

I tried it 3 times: 20201116 20:09:15, 20:09:44 and 20:13:44.

These issues do not occur when the focus metric is set to SGP HFR. Note that using ASTAP for Plate Solving works fine for me. According to ASTAP’s Help/About ASTAP Information, the version is: 80.9.447 64 bit, dated 2020-11-02.

Furthermore there is a problem with the transmission of an issue report: first time I set up this report in SGP. When I tried to send the report (not having checked the option ‘Post to the public support forum instead’), an server error occurred, and the report WAS LOST!!! That’s not funny.


Link to Logs

Approx time of issue: 16.11.2020 20:09

Useful Info

OS: Microsoft Windows 10 Pro

@Jared or @Ken please take a look.


Bernd - I saw the same last night. I was just trying it for the first time and thought I had changed exposure somehow.

Running your sequence now and it seems to be setting the exposures correctly, at least in my test environment. I’ll run some tests with my actual setup and see what could be causing the issue.

Was this happening pretty reliably for you? All 3 (ASTAP, SGP and Pinpoint) “metric providers” now use the exact same code for capturing an image so it seems odd that the exposure could differ between any two of them for the same settings.


I ran some additional tests with my remote setup and the SGP4 Beta and was unable to make make this happen. Any other additional steps to reproduce?

Thank you,

In my case, I had started the sequence using HFD and while running, changed it over to ASTAP in the control panel. I will see if I can find the log entry.

Hi Jared,

I am sorry, in this case it might indeed be an user error. For the first time I tried to use a filter drawer and the STC Duo Narrowband filter with my OSC camera. The configuration of the filters (STC and None or Lum) in the manual filter wheel was not correct at the beginning, so I aborted the sequence, edited the filter list and then continued the sequence. I believe that this mixed up the assignment of the filters.

I will observe whether this issue arises again and report.


I’m sorry - looks like I fell into the same trap. I disabled AF with LUM but forgot to set the AF exposure times after a driver install. I have put that right and will confirm that was it.

:+1: I’d be REALLY surprised if you were able to get different exposure lengths at this point between ASTAP/SGP/Pinpoint as the portion that takes the exposure is all shared between the 3 and the “metric provider” is only responsible for actually running the analysis…now I would NOT have been surprised if you had this issue prior to adding in the ASTAP metric… :grimacing:


Yup - it is working fine. The same cannot be said of my roll off roof. You think you have thought of everything but failure modes come out of nowhere. In this case, the roof was still open when the sun came up. ASCOM was reporting a shutter error. What possibly could I have done wrong? I could not make head nor tail of the logs so I closed it manually with its RF remote, in the distance I could hear the rumble.
I looked out the window, the roof was still open. Donning a coat over the PJs I plodded out to see what was going on.
My rool off roof uses a driveway gate motor and it has a bounceback feature. The heavy dew overnight had frozen on the rails and was sufficient to cause the feature to kick in. I’ll have to write an ASCOM driver for a heated rail…

1 Like

Now that has to be in the running for the “most obscure failure mode” prize Buzz :smile: