SGP and Blue Screens

Good morning. I have been using SGP version with ASCOM 6.1 SP1. I run Windows 10 which is very stable, and I have Windows Update disabled so nothing gets messed up by sudden update prompts or reboots.

On the past two nights, something has caused my computer to reboot. Last night, the reboot happened after my imaging run was complete. The night before, however, it rebooted after only two frames - I lost my entire night of imaging.

The logs are here:

Also, I checked the system event viewer, and found the following message at 6:30am this morning:

The computer has rebooted from a bugcheck. The bugcheck was: 0x0000003b (0x00000000c0000005, 0xfffff8005aa73d4a, 0xffffd00021bfba70, 0x0000000000000000). A dump was saved in: C:\Windows\Minidump\060716-9750-01.dmp. Report Id: b6b8a9d8-e6ff-4836-b7c2-ab3af22d7001.

I believe this indicates a Blue Screen of Death reboot (though I have no idea what color it actually is in Windows 10 :grin:). When I get home from work tonight I’m going to update to the newest version of SGP, in case this issue is fixed in a later version. But in case it was not, consider this a bug report.

I just hope somebody will know what caused this, because I don’t want to lose more imaging time.

Thank you, everybody!

It is almost impossible for software to cause a BSOD. BSODs occur at very low levels in the kernel. The “best” that software can generally cause is the application freezing or causing a “The application has stopped responding”.

Let us know what you find but I would run SFC and see if it reports any issues:

And yes, Windows 10 does indeed BSOD with a frowny face. My latest laptop had some cooling issues (fixed now) so I was seeing BSODs about every 10 minutes : (


Thanks, I will run that tonight when I get home.

Did your analysis of my SGP log find anything unusual?


I honestly didn’t look at it earlier. But it appears to be unavailable now (404)


My mistake - I had the file in the wrong directory. The link should work now.


I had several nights killed by the BSOD. I downloaded BlueScreenView, ran it, and it showed that the driver for my TrippLite Keyspan USB to serial adapter was a common denominator for at least the three previous crashes.

I replaced that USB to serial adapter and so far no more BSODs.

I’m running Win 7.

Jim seargeant


I had never heard of that utility before, but I tried it out. My two crashes were SYSTEM_SERVICE_EXCEPTION and DRIVER_IRQL_NOT_LESS_OR_EQUAL but both times the “Caused By” was the Keyspan USB adapter.

Unfortunately, I have to use two of them - one for my mount, the other for my RoboFocus. I was previously using a much older laptop and never had a problem. This new laptop has been trouble free for a couple weeks, but having this error two nights in a row is disconcerting. One difference is that the new laptop only has two USB ports instead of four (meaning I could have each USB device in a different port) - but now I have the two Keyspan adapters hooked into a good USB hub along with my autoguide camera, and the other port goes to my QSI imaging camera (I want that on its own dedicated port).

I am using the most recent driver, so I just tried doing a reinstall of the driver. We’ll see if that makes a difference. If that doesn’t work, I may try downgrading to Windows 7 (though in many ways I consider that an upgrade in and of itself).

Thanks for the link, Jim! I actually work in the IT field of a local school district, so that Blue Screen utility is going to come in handy!

This was the first time I used BlueScreenViewer - yes, it does seem useful. (Sadly)

The Keyspan USB to serial adapter is widely recommended, but I replaced mine with an old Edgeport USB to 4 serial port adapter and no more BSODs - so far. I also have a Startech USB to 4-serial adapter but haven’t tried it yet.

It appears that others have had this problem: a search for “BSOD Keyspan” pulls up many hits.

I’m sticking with Win 7 until …?

Jim Sgt

Any USB-to-Serial adapter containing FTDI chip works best. Some examples I have that work well for all Windows OS up to Windows 10: