SGP and custom tracking rates

Trying to image comet Borisov with a Paramount and TSX there was a gotcha. TSX will do a custom tracking rate but when that is enabled, SGP sees that it is not tracking at sidereal and insists on setting it back to sidereal rate or the sequence will not start. Worse yet, it will not dither by mount and still insists on setting back to sidereal rate (apparently thinks it is not tracking).


look forward to the image once you get a fix… I can still remember the last one you posted…very ethereal

no pressure…

Will add this to feature requests

1 Like

yes, I stumbled into this one, if I set custom rate in TSX and then run the sequence, it resets back to sidereal

  • the only work-around is to set the sequence running and then immediately set the custom rate in TSX.
    I guess the fix is to check the tracking status and only issue a tracking-on command if it is not tracking?

There isn’t anything to do in SGP here. When we ask the mount “Hey, are you tracking?” it says “Nope, I’m not”. This seems to be an issue that needs to be resolved in the TSX ASCOM driver. Also it seems odd that enabling tracking resets the tracking rate in the driver as well. Also something that probably needs to be addressed in the driver.

We never query the mount for its tracking rate nor do we care what tracking mode it is currently in other than “tracking enabled”. The most we do is ask for a set of supported “Move” rates that are only used in manual movement area of the Telescope Control Panel.

We will not dither as the mount is saying it is not tracking. We do not set it back to sidereal rate…this must be done in the driver. ASCOM does expose the options to control the Rates of the Axis. But we do not use them.


Thanks for the clarification, I will bring this up with SB. At the same time I discovered that if I acquire the comet images through TSX, they have different physical dimensions to my calibration files taken with SGP.


Not too surprising as they’re likely using a different driver. If you use the ASCOM driver in both then they should remain the same (assuming that’s an option). But then again they could write the fits differently as well.


yes - the SGP files are spot on - the TSX driver adds a black margin…I guess it is taking in the overscan area too