SGP and HEQ5 mount drivers

Help! This is driving me crazy. I have set up Sequence generator Pro with a Primalucelabs Eagle 4. I have an HEQ5 mount and I can’t get SGP to connect with the mount. I have installed EQMOD HEQ5/6 but that is asking me for a port number. In the Eagle 4, ports tell me the ‘serial port’ is COM34 but in ‘driver set up’ the ports only go up to 16. I am stuck at this point.**

Also, how does the Eagle 4 communicate with the mount? Should there be a cable from Eagle 4 to the mount? Or handset?

Link to Logs

Useful Info


I’m not entirely sure how the HEQ5 connects. There will certainly be a cable somewhere. Probably best to consult the HEQ5 documentation for that piece. From there you should be able to get the COM port out of your windows system settings (plugging and unplugging the device is a quick way to figure out what port is actually getting assigned).

At that point you can plug the COM port into EQMOD and hopefully that should get the device talking to EQMOD. From there you just need to tell SGP to use the EQMOD driver and you should be good.


Thanks Jared. I connected the SynScan hand held unit to a USB port on the Eagle 4. It has registered on the Eagle 4 computer, but it as port ‘COM36’ which isn’t being offered up as a port option by EQMOD ASCOM connector.

You need to change the COMport number, look here How to change the COM port for a USB Serial adapter on Windows 7, 8, 8.1, and 10 - Plugable Knowledge Base

Thanks - that changes successfully to COM2. I then went to EQMOD ASCOM set up and changed the port details to COM2. But it is still giving me ‘connection error: port not available’ in the EQMOD window. Any suggestions gratefully received - thank poi for helping so far!

I never used the PC Direct mode so i’m not very familiar with it, but i think there is some kind of PC Direct mode that has to be enabled on the handcontroller.
Most people use EQDIR cables so they don’t have to use the HC.

Okay - thanks so much for this - I will have a look.

Okay Direct mode has enabled me to gain slew controls now in EQMOD HEQ5/6 and the mount position is coming up in the numbers for RA Dec etc- thanks. But the port COM2 with the USB connection to SynScan is still not being recognised. So the connection with SGP isn’t being made yet. What can I try please?

Unfortunately I’m not well versed in EQMOD. Once you have your mount connected to EQMOD all you should need to do is tell SGP to use the EQMOD ASCOM driver and you should be good.


How old is your HEQ5 mount ?, what type of serial port \ hand controller port does it have ? and I take it you’re trying to connect\drive it through the hand controller ??

Do you have a USB to serial adapter e.g. (Lynx Astro FTDI EQDIR USB Adapter for Sky-Watcher Mounts (see description for models) | First Light Optics) [although they are easy to knock up…] This would eliminate the hand controller, and drive the mount directly from the eagle via EQMod\Ascom…

My mount is a year old. I am using a USB type B into the synscan. Then a normal USB end going into the Eagle 4. That cable looks like a good prospect and I will buy one. Thank you for your advice.

Most Astro Photographers usually eliminate the hand controller & drive directly, as it eliminates a potential problem in the middle …

Thank you Dr Ju Ju - useful advice and I just ordered a cable to go directly from the mount to the Eagle 4 for that reason. Hopefully that will help me solve this. It’ll be neater in terms of cable management also I think.

I’m not 100% sure, but I thought COM1 and COM2 were reserved by Windows and you have to start with COM3.

Thank you - will try Com3. Also waiting for a new cable due to arrive today.

Still trying to solve this and connect my Primaluce Eagle 4 to my SkyWatcher HEQ5 Pro mount with EQMOD ASCOMso I can operate SGP . Hopefully this will explain a bit more precisely how things are going wrong…

My Skywatcher HEQ5 mount is connected to a Primaluce Labs Eagle4 by a cable which goes from the mount (from the connection that the handset would normally go into) and leads into what I have determined to be USB Serial Port COM36.

However my problem is this: I can’t connect EQMOD to COM36 because the digits under the binocular logo in ‘EQMOD Set Up’ only go up to 16.

If I then try to alter the port COM number in device manager, under advanced port settings, ‘in use’ is noted next to all the COM port numbers up to 35, so I can’t change the port number below 36. This is the same when I disconnect all devices.

If I try to change the port number to a low number that is ‘in use’ I get a warning message telling me the COM name is ‘in use’ and that duplicating names will screw up the system.

Would really appreciate some advice on this as it is driving me crazy. Thanks in advance!

You can free up the “in use” COM ports, i suggest you do a google search to find a guide on how to do it.

Thank you Xplode. I will try that next.

This worked and EQMOD is working now. Link to mount all good. But, weirdly, SGP will not open now. I reloaded it but it still will not open. It was opening and all fine until I got EQMOD working. Any suggestions please? Thanks in advance.

I finally solved this by uninstalling everything and re-installing. Thank you for your advice everyone.