SGP and LX200 Protocol and errors during connecting

Hello there,

I have a Losmandy G11 with FS2 which actually connectable via LX200 Protocol…

Connecting MximDL and PHD/PHD2 works with the FS2 via USB-SERIAL Adapter…
but when i try same with SGP, 2 errors are generated… did capture the errors as screen hot for you…

Question !

Why does SGP not manage to connect to my SCOPE via LX200 Protocol ?

Thank you


Hi Martin,

Please see this post (ignore the part about searching the forum) and we’ll see what we can find:


Hi Ken,

Thank you for making me aware how to use the HELP FUNCTIONALITY… if you wouldn’t have told me, I would have never known, that there is a HELP FILE !! JOKING THOUGH !!

Ken ! i did look and search the help file and also the forum… by using the search functionality for FS2… and did not find any !

I am excited to read your answer and explanation… why SGP is not able to connect to FS2… but MAXIL DL, PHD, PHD2, CARTE DE CIEL does…

Thank you


We need the following information in order to assist you (copied from the post that Ken referred you to):

  • Operating system
  • Version of SGPro
  • A link to a log file showing the incident (failure). Help->Open Log File (for the current run). For a previous run, Help->Open Log Folder (SGPro saves logs for 2 weeks). This forum does not allow for attachment of large files so you will be responsible for hosting your own files ( is a great free service to take advantage of for this task).

Without this information we can’t be of any assistance.


HI Jared,

OK, you will get the details you need and ask for… i will send you the details, soon !!

And regarding your comment…"This forum does not allow for attachment of large files so you will be
responsible for hosting your own files ( is a great free
service to take advantage of for this task).

OK… NOTED will try not to forget it !


Hi Jared, here we go…

The answers ! to your questions and the LOG File… ( not a abig file ) and sorry, i do not like to put any files into DROPBOX…

Operating system = Win7 74 BIT
Version of SGPro = BETA ( registered version ) and not the free trial version…
and see attached file, did try to connect again few minutes ago… and same error…

Thank you

Martinsg_logfile_20150518200358.txt (48.5 KB)

Hi Martin,

Thanks for the logs. A couple things to note:

  1. This driver is not ASCOM compliant. This is just an indicator… we could probably work around this, BUT
  2. More importantly, we currently do not support mounts that only report they can slew with Alt/Az movements.

I will make a note to fail on connect for these mounts to make it less confusing.


From what I can see the driver is reporting that several things are not implemented.
In detail:
Read SideOfPier
Read of Altitude

From a look at the LXP driver source this is an early driver which only implements version 1 of the ASCOM protocol, the first three of these aren’t in version 1.

There’s no indication that the mount can only slew in Alt/Az, more that it can only slew to Ra/Dec coordinates.

The driver implements read of right ascension and declination, slews to RaDec positions, syncs to RaDec positions and PulseGuide but not much else.

That’s enough for a simple program such as CdC to be able to read the mount position and do slews but SGP needs more than this. It doesn’t mean that the driver is not ASCOM compliant, more that it’s not SGP compliant. SGP needs more than ASCOM compliance.

It’s a shame but a lot of mount manufacturers don’t seem to do anything to support external control of their mounts. A lot simply implement the LX200 protocol - more or less - and hope that someone else will provide a driver.

It’s possible that a different driver that supports the LX200 protocol will work, but I don’t know which.


Hi Chris,

Thank you for your answer and feedback, I did forward your answer ( Technical Part only ) to the developer and manufacturer of FS2, so the developer can review and find a solution and correct the issue…

Thank you for all your efforts and hope a solution could be found so SGP can work with FS2… also !

Thank you


I’d have been happy for you to forward the lot. Manufacturers need to understand that a decent driver is almost essential nowadays. Users should be telling manufacturers that they won’t buy their kit without a good, supported, driver.

Would you buy a printer if the manufacturer published a protocol and said that he hoped that a user might develop a driver for it?


Thank you Chris,

I understand and do agree with you ! I by SURPRISE have also another Mount control system (LFEP V40) and SGP works GREAT with this one… I will just use LFEP V40 ! iso FS2 and stop using FS2 !

Thank you very much and best wishes


The errors that are thrown about in the log seem to contradict this.

18.05.2015 20:06:35] [DEBUG] [CP Update Thread] ASCOM Telescope: Error in GetCurrentPos : Property read LXP.Telescope Altitude is not implemented in this driver. (System.Reflection.TargetInvocationException: Ein Aufrufziel hat einen Ausnahmefehler verursacht. —> System.Runtime.InteropServices.COMException: Property Altitude is not implemented in this driver.

I say this because I have inside knowledge of how this function is structured. The error is thrown when attempting to access the Altitude property and the function is structured as such:

if (tel.CanSlewAsync || tel.CanSlew)
    ti.nRightAscension = tel.RightAscension;
    ti.nDeclination = tel.Declination;
else if (tel.CanSlewAltAzAsync || tel.CanSlewAltAz)
    ti.nAzimuth = tel.Azimuth;
    ti.nAltitude = tel.Altitude;

Notice that the "Azimuth property is only accessed if the telescope reports “false” for both “CanSlew” and “CanSlewAsync”.

This is really strange because both CanSlew and CanSlewAsync report true.

Public Property Get CanSlew() As Boolean
CanSlew = True
End Property

Public Property Get CanSlewAsync() As Boolean
CanSlewAsync = True
End Property

I can’t see a reason why the reads of Ra and dec should not be done.
In addition CanSlewAltAzAsync and CanSlewAltAz are not implemented so if the code reaches the else clause an error will be thrown. I don’t see how the reads of altitude and azimuth will ever be reached in this code fragment when using this driver.


Ah, never mind. You are right Chris. I found a less apparent path that can access altitude and azimuth for a mount that implements slew. I will tidy that up… I don’t accessing that property in this case is necessary (old code).

Anyone tryed or could try if this drivers works properly?

Hi Andrea, yes it works, but with Telescope Drive Unit FS2 ( actually ), do you have such a drive unit ? if so, then it works… there are many threads and feedback from users in a german astronomy forum…

No reports or feedback that it works in combination with a special software… but it works for what it is designed for… with FS2



I am the developper of the AdvancedLX200. Please try this version

in this version Get Altitude and get Azimuth are implemented.
This version support also Pulse guiding and works with PHD2

If you have question in german please ask me here:

If you have question in french please ask me here:

For developper:
Ascom yahoo group


1 Like


I got some Problems with FS2 using the lx200 Protocol when using skysafari.
The vixen skysensor 2000 seems to Be very similar to FS2 regarding Mount control. When using the vixen skysensor Protocol everything worked Fine .

So maybe you give that Protocol a try, if available in Main Sequenzen?