SGP crash with Nikon camera

Description

Connecting a Nikon D7100 camera to SGP results in an immediate SGP crash. This is 100% repeatable.

Aprox time of issue: 12:14

Link to Logs

Useful Info

OS: Microsoft Windows 10 Pro
Ver: 3.1.0.558
.NET: 4.8

Are you using the battery or external power source?

I’m connected to an external power source.

The reason I ask is that I had similar issues on my D5100 and it ended up being that the DIY power supply I made wasn’t doing something right. Upgraded the power source and the problem went away.

Should work with a fully charged battery too…

Thanks for the tip, but this issue (D7100) happens on 3 different PCs, and on Windows 7, 8.1, 10, and 10 Pro. I’ve tried all combinations, and it’s an issue with SGP and the D7100. Very frustrating.

I’m going to guess you tried a different USB cable as well?

Well, I gotta admit, I haven’t. I convinced a friend of mine that SGP is definitely the way to go, but she had these crashes when she tried to run it. I volunteered to look into it and took her camera (7100) home, together with her PC. I’m a Canon user, and the Nikon USB cable is a Nikon specific one, so I don’t have anything I can replace it with. The camera does connect to applications such as FoCal and Helicon Remote on a Mac, so that gives me some confidence that the cable is OK.
Still, when I see her again I’ll try replacing the cable to see if that’s the issue, but until that happens I’m stuck.

You may have to reinstall some of the visual C++ redistributables. 32 bit. I forget which year specifically. There is one that does a batch of years in one update…

Try the 2013 one as well.

https://support.microsoft.com/en-ca/help/2977003/the-latest-supported-visual-c-downloads

Yay! I installed all the VC redistributables I could find on the link you provided, both x86 and x64, and now it works. I thought I had done all of them before, but it was a lot easier having them all in one place. Thanks for the pointer, and my friend is now a happy camper who is playing with SGP (and will probably purchase it).

Thanks again!