SGP crashes with QHY10


<I have used SGPro fr some time but with a DSLR and had no issues. I bought a QHY10 OSC some time ago and thought I would connect it up now I am familiar with SGP. I have loaded the latest ASCOM platform, the latest QHY10 driver and software etc. I have started up SGP, connected a simulated ASCOM telescope and then connected the QHY10 camera and it seems ok. I can open the camera settings and all seems well. I was trying to determine the Gain and Offset settings by taking a Bias frame (some info from the internet) using the Frame and Focus tool. Using binning 1*1 and doing a exposure = 0 (I also tried 1s
as well). In each case SGP crashed. I looked in the logs but could not see anything obvious however, there was a screen error that was too fast to read but I took a video and it said Error #15 initializing libiomp5md.dll, but found libguide40.dll already initialized >. I also tried to do a bias frame by running sequence but to the same effect, it looks like it is starting to do something and then crashes. I have searched the forum and did not find a solution and I have similarly searched the web. Looks like a dll conflict but not sure how to resolve - grateful for any help. I would like to get this resolved as I would like a QHY163 and Filter wheel but will re-consider if there is an issue between QHY and SGP. Thanks in advance.

Aprox time of issue: <1335>

Link to Logs

Useful Info

OS: Microsoft Windows 10 Home
Ver: 10.0.18362 Build 18362
.NET: 4.8

I think you have attached the wrong logs. If SGPro crashed, you will want to pick the log where the crash occurred and not “Current Session”.

Hi Ken,

thanks for the reply.

That session did bin out as well and so that was the correct log; I did scan the other logs as well and could not see any obvious issue. However things have moved on since then and I found a internet string for that Error #15 which addressed the conflict but then brought up another issue ‘Problem Loading ippSP library No DLLs were found in waterfall procedure’ and so as I solved one problem it unveiled another. I have the same software (different build of SGPRO) on my Main PC and so connected the QHY10 to that and it all worked and so I knew it was just the laptop and yes, with hindsight, I should have tried that first! In the end, I removed SGPRO, EQMOD ASCOM software and all the QHY drivers, restarted and then loaded ASCOM, then SGPRO and then the QHY driver and software and it all works. No idea why it did not work the first time as I have not changed or removed any software but in fairness I had not connected the QHY10 for a couple of years. First light is likely to be Monday or Tuesday as the skies are unusually good this coming week.