SGP does not see its RA+dec in FITS header

This shows the problem that I have previously reported: an image containing all the valid info is loaded into SGP yet will not solve automatically within re-typing all the FITS data in manually. The picture shows the header and the message claim.


I cannot reproduce this. Can you please post the image on dropbox or similar?

Sorry, I can’t quite follow this? The picture shown above is the full-scale screen dump. Can you clarify please?


I was asking for you to post the image you are trying to solve to Dropbox.
The actual fits file that is giving you problems, not the screen shot

OK - I’ve done that. I opened an account with Dropbox but the file appears to stay on my laptop (where it was originally!) so its not clear to me how I get it to you!


Thx. Unfortunately, I cannot reproduce the problem. This is from the image you posted:

OK - I’m bewildered. SGP doesn’t see any the RA/dec data in the headers - at least where I live.

I cannot see where the problem is.

Lawrence :confused:

Me either. You live in the UK? I thought you did so I set my region there
prior to testing. Please correct if I am wrong.


I have seen this failure, as well. In v2.4.3.1 frames were being saved without having the RA and DEC coordinates stored in the FITS header. When PlateSolve2 was invoked it showed zeros in the RA and DEC “hint” fields.

Here is a sub where that happens:

Dropbox - File Deleted

When I right click the image and pick Plate Solve, I see this:


Thanks goodness someone else can reproduce this! FWIW The FITS header doesn’t show the correct telescope or camera but the RA+dec is correct. I had not changed over the equipment profile during these tests (because I forgot and I am still learning SGP) but the result was clearly wrong for other reasons.

FWIW yes I live in UK. At least it did use Elbrus to solve the plate. It also solved it correctly after I entered the RA+dec hints entry.


I had 1 hour of clear sky this evening. The plate solve option live was picking up the RA+dec (yippee) but was not picking up the plate scale (ummph) - so I had to enter that. Unfortunately not a single live plate would solve in Ebrus - regardless of setting. I even tried 40’x40’ any angle - centred on M15 star cluster (!) but it still would not solve.

I’ll examine these again in the morning (I’m tired and its late).



You guys are talking about 2 different things…

@Lawrence Your issue is that FITS headers that are present are not being detected and populated into the appropriate fields (I cannot reproduce this, nor do I know of anyone else having this issue).

@chasmiller46 Your issue is that the images do not contain RA and DEC entries at all. This will be true if the telescope is not connected. This looks to be true in this case or your image would have a TELESCOP entry with the mount you are using.

What application captured this data? If it is an image similar to the one above, then SCALE was never written to the headers.

OK - I guess I really have problems. See the Elbrus section for last night’s analysis.