SGP don't recognise my 8 filter wheel


Not sure if this has happened to anyone else, but if it has I love to hear what you did to solve it.

I have a QSI 638 sw 5 which I recently upgraded to an 8 filter wheel carousel. I followed the instructions, changed the 5 filter carousel to the 8 filter, flipped the internal switch from 5 to 8.

What happens is that SGP don’t recognise my 8 filter carousel. in fact the filter wheel function do not even work at all now.

Need to update the driver ??

for the cameras you mean ?

I have tried

I don’t know the devices, but I meant for the filter wheel, if it uses one ??

Yes it does, unfortunately it seems to be something with QSI as Maxim DL also has problems accepting the carousel.

You might try downgrading the driver. I couldn’t get the newer driver to work either on my 8-position wheel (albeit on a QSI 690). An older driver has worked for me, though (version 7.4.1824.0).

Best regards,


The issue was mechanical. QSI had somehow fitted the T-mount adapter with screws that were too long which resulted in my carousel not being able to move.
Problem solved :slight_smile:

I am glad you got that resolved and sorry to hear that QSI (or ATIK, I suppose) caused your problem and didn’t realize it. Clear skies…