SGP failed to activate PHD2 despite it working fine

Last night I had a fully repeatable failure mode. I had set SGP to activate PHD2 quite routinely and it normally works - but last night it just sat showing the 'waiting for PHD2 etc notice. PHD2 was working correctly and had been activated using ‘connect all equipment’. This error forced me to manually reconfigure to do it myself and there was a consequent loss of several images. the problem was noted at about 2310pm.

I tried powering down SGP (highly undesirable because it affects camera temp) and also pwered off PHD2. I reactivated SGP and connected all equipment. The failure mode immediately happened again and I gave up after more than one attempt. PHD2 was sitting there fully ready to go - so what does SGP expect to happen that was not happening? I hope smeone can analyse the log and identify whether I did something wrong.


Lawrence Harris

Approx time of problem <2310>

Link to Logs

Useful Info

OS: Microsoft Windows 10 Home
.NET: 4.8

Unfortunately I have just remembered one change …. I upgraded SGP to the latest version! Is it possible to downgrade quickly?

Lawrence :thinking:

On the main page of SGP website (see link) there is an Archive of many of the prior releases (will need to scroll down). Just download the version you want. You may need to uninstall the version you have, however the older versions are always available.

Just out of curiosity, are you relying on SGP to start PHD2 and get everything going, or do you start PHD manually and then try to start the sequence? Just a thought, if you are relying on SGP to start everything, perhaps try manually starting PHD2 first and then try running the sequence. See if SGP will communicate with PHD2 that way.

No I am not. I first check PHD2 with a test run to confirm all is
well. Then I use ‘connect all equipment’. I have tried different
variations but it repeatedly refuses to collaborate. I also fund
that there is only one version of v3 on the archive page - not the
complete list. My own earlier versions (FITS header data) show
various releases. FWIW I have fitted a reducer and amended the
scale data per configuration. Solves are usually OK but SGP refuses
to see PHD2 as ready to roll.
Curiouser and curiouser …

I have only just realised that the versions /are not in chronological
order/ =-O so I had not realised that I can download the last version!



“I reactivated SGP and connected all equipment. The failure mode immediately happened again and I gave up after more than one attempt. PHD2 was sitting there fully ready to go

Lawrence, from your information I can’t work out whether you are allowing SGP to launch PhD, or you are launching PhD manually. If you are launching it manually, please try not launching it manually and allow SGP to launch it.

I have on occasion found that SGP will not communicate with PhD2 if I manually launch PhD and then select “connect all equipment” in SGP. So, I now never manually launch PhD; I let SGP launch it via “connect all equipment”. Not sure if that will solve your problem but you never know your luck in a big city.

Hello Ross

To re-cap: I did try both methods; the normal one of using SGP and
‘connect all equip’ to launch PHD2 (which it didn’t) and ‘connect …’
when PHD2 was already launched and waiting. Neither worked - and as
mentioned, it had always done so.

Yesterday I realised that the only change since the last imaging session
was the ‘upgrade’ so I had planned to re-install the previous version.
However, last night I decided to go with the latest without making any
changes. To my amazement everything worked normally!! No changes at my
end - it just worked as normal. Therefore the ‘problem’ is fixed
without my having knowingly done anything. Even yesterday I did do a
full program close-down and restart but it would not work.

So to conclude - it is now working once more. I wish I knew what the
cause of the problem was.

regards to all

Lawrence Harris

Good to hear it’s all working now Lawrence.

Clear skies.


Make sure you’re not running SGP or PHD2 as Admin as well. That can cause communication issues.

If you’ve just installed a new version of PHD2 or SGP it’s also possible that there was a popup asking for permission to allow certain ports through the firewall. Be sure to accept this, otherwise the firewall will block communication.


As I reported later, the following night everything worked correctly
even though no changes had been made.
Lawrence H