SGP Hangs when using the new PHD2 settings button

I just installed beta on two computers, and on both when I try to access the new PHD2 settings from the equipment profile settings it causes SGP to hang. On both computers I was able to point SGP to the PHD2 install directory, but clicking the “refresh profiles” in PHD2 settings caused the hang.

On the first computer after a couple of hangs I was able to update all my profiles to reflect the correct PHD2 profile settings for each SGP profile.
Computer 1 log file

With the second computer, SGP hangs immediately when trying to access the PHD2 settings and I was never able to update the SGP profiles.
Computer 2 log file

In both cases I let SGP hang there for a while just to make sure it wouldn’t recover, which it never did.

On closer inspection, it appears as though both PHD2 and SGP are “busy” or hanging for some time. Perhaps SGP is waiting for PHD2 and timing out? Eventually (after several minutes) I’ll get a timeout message in SGP, after which PHD2 and SGP do “unhang” but clicking the “refresh profiles” button just causes the same hangs.

And finally, here’s a last error message I receive. Notice that despite the message PHD2 is open.

Thanks Joel…

Sorry to be obnoxious, but I think the PHD2 debug logs will be just as important to stabilizing this feature set. Do you still have those? Or can you reproduce the error and send?

@Andy and I both tested this pretty thoroughly so it’s pretty disheartening that it broke so easily…

Don’t feel bad Ken, I’m good at breaking things!

I am not sure which PHD2 logs were the correct logs, so I’ve put several logs into zip files. All these logs deal with the issue, just not sure which ones specifically.

Computer 1:

Computer 2:

Ok, thanks. Not a lot to go on here. Looks like PHD2 never even got the request (but you said PHD2 was locked up also?)… Can you do me a favor, and when this happens, completely close PHD2 and let SGPro open it with the “Settings” button (essentially a full reset)? I am wondering if the socket to PHD2 has gone bad in SGPro with the way you went about clicking through stuff.

Actually I can’t seem to reproduce this now. It took several tries this morning, but once I got all my equipment profiles setup with the correct PHD profile I can open the PHD settings dialogue without problems.

Just to be clear, the hangs happened the first time I tried to open the settings. I simply started SGP, open the equipment profile manager, chose the profile and clicked on the settings. It asked me to point to the PHD2 application directory, which I did. When I tried to refresh the PHD2 profiles that’s when the hangs occurred. And yes, both PHD2 and SGP were stuck. However, they both eventually unstuck after a few minutes and I could then choose the PHD2 profile.

I also had same behavior on the Settings button on Other | Observatory tab last night with My sequence was running and I wanted to check the Observatory Settings since my dome was not following the mount as closely as I needed it to.
Both SGP and PHD2 appeared to hang, although both were using varying amounts of cpu. After a couple of minutes I gave up and restarted them. I can look for the logs if you want them.

We can’t be of much help without both sets of logs (since we cannot reproduce it).

Actually… hold off on digging through the logs. I have still not been able to reproduce, but I changed some stuff around that is highly suspect. These changes are not in the beta. I will release them soon…