SGP has stopped working for me

SPG hangs for me before it starts. it gets to the “Checking License Status …” of the startup screen. I then get a windows error that “SequenceGenerator has stopped working” with a “Close Program” button.

I have tried uninstalling and reinstalling, but I get the same problem. Based on other threads, I also tried moving all my profiles out of the “C:\Users\YourUserName\AppData\Local\SequenceGenerator\Sequence Generator Pro” folder. But that also hasn’t changed the error.

I was changing the “End Point” setting for plate solving in the “Other Plate Solve Options” window when SPG crashed and caused this problem.

Any advice is appreciated.

I seems like maybe your settings are corrupted… You might need a complete reset of SGPro settings. Open a command prompt, navigate to the install directory, run:

Sequence Generator.exe /reset

Embarrassingly, I am having trouble trying your suggestion.

I run the cmd shell. Then I use the “cd” command to get to the install directory, which is “C:\Program Files (x86)\Sequence Generator” in my case. Then I run the following command:

start /wait “” “Sequence Generator.exe” /reset

Which runs SGP, but gives me the same error. I learned all this from Google in the past hour or so. I don’t know if the /reset parameter is running.

I use Excel for my day job. Any help is appreciated.

After some research, I think I am executing it correctly in the command prompt. But SGP still won’t run and errors out.

It is creating a log file, which I have attached.

Looks like you’re attempting to output images to a network path. Unfortunately this isn’t supported at the moment. You can likely make it work with a mapped drive…but it will generally be best to save them locally then move them later.


Thank you -

For others, I got it working by deleting the parent folder the where logs were stored. In my case the path was \users<my user name>\AppData\Local\SequenceGenerator.

Once I deleted that folder, I was able to run SGP, Uninstall, & Reinstall. All my settings were deleted, so I copied my equipment profile (which I had previously saved to my desktop) back into the “C:\Users\YourUserName\AppData\Local\SequenceGenerator\Sequence Generator Pro” folder.

Thanks for the great program, and it should all be good now.

Probably self-inflicted, but a catastrophic error that took me several hours of troubleshooting to fix. After reading all the related posts, looks like there is a common theme of plate solving settings & using remote drives that causes a setting corruption that prevents SGP from loading.

Thanks for posting your solution.